This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Websphere and the fly likes Installing Rational XDE v2002 Release 2.1 on a machine running WSAD5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Installing Rational XDE v2002 Release 2.1 on a machine running WSAD5" Watch "Installing Rational XDE v2002 Release 2.1 on a machine running WSAD5" New topic
Author

Installing Rational XDE v2002 Release 2.1 on a machine running WSAD5

Krishan Leekha
Greenhorn

Joined: Feb 26, 2002
Posts: 13
I am trying to install IBM Rational XDE v2002 release 2.1 on my machine which is running WSAD 5. But it does not allow me to do so and throws the following error:
"IBM Websphere Studio Application Developer 4.0.3 is not detected. Please install it first."
I read the release notes which says while installing it checks whether WSAD4.0.3 is installed on the system or not.
I am wondering if is there any way to install Rational XDE v2002 release 2.1 on a system running version of WSAD other than 4.0.3 ?
And any idea about which version of Rational XDE is compatible with WSAD 5 ?


- Krishan Leekha

Do not wait for leaders.Do it alone, person to person. - Mother Teresa
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
Rational XDE 2003 installs on WebSphere 5.0. You need to upgrade to XDE 2003.
Kyle


Kyle Brown, Author of Persistence in the Enterprise and Enterprise Java Programming with IBM Websphere, 2nd Edition
See my homepage at http://www.kyle-brown.com/ for other WebSphere information.
Krishan Leekha
Greenhorn

Joined: Feb 26, 2002
Posts: 13
Thanks Kyle.
Upgradion is one option, but my organization already has lienced version of Rational XDE v2002 Release 2.1, and upgrating to Rational XDE 2003 may take some time. In the mean while I was looking out the if I can use the older version of XDE with WSAD5.
I found some thing on IBM's site regarding using XDE with any WSAD other than 4.0.3. ( Attached below )
But unfortunately that too is not working ! Even after creating the required entries in registry, it is is still checking for the WSAD version.
I am wondering if some one has sucessfully tried some thing of that sort ?
From the URL: http://www-1.ibm.com/support/docview.wss?rs=203&context=SSSJ2Z&q1=Rational+XDE&uid=swg21129047&loc=en_US&cs=utf-8&lang=en
************************
QUESTION: Is it possible to install Rational XDE v2002 Release 2 for Java on a machine running a version of IBM Websphere Application Developer other than 4.0.3 (for example, v4.0.2 or the new Integration Edition)?
ANSWER: Rational XDE v2002 Release 2 for Java has been tested with version 4.0.3 of IBM Websphere Application Developer. Using it with any other version is not recommended or supported at this time. However, if you wish to proceed with the installation, the Rational XDE Java Platform and Workbench Edition v2002 Release 2 Release Notes contain the following workaround:
� As part of the installation process, the Rational XDE installation program checks that your operating system is on the list of supported operating systems. If you are installing over IBM WSS AD, it checks that you have installed the correct version of that as well. Normally, if your system does not have the required characteristics, installation will not continue. If you need to bypass these installation checks, you can do so, by using regedit or a similar tool to create the following registry keys. Please note that installation to untested or unsupported environments is at your own risk.
o To bypass operating system checking : HKEY_LOCAL_MACHINE\Software\Rational Software\RSSetup\OsCheck
o To bypass IBM WSS AD version checking: HKEY_LOCAL_MACHINE\Software\Rational Software\RSSetup\IdeCheck
************************
Kyle Brown
author
Ranch Hand

Joined: Aug 10, 2001
Posts: 3892
    
    5
It won't work, period. WSAD 5.0 and WSAD 4.0 use different versions of the Eclipse platform. If you try to install a back-level plugin (like Rational XDE 2002) on WSAD 5.0 it will either not install, or fail to work.
Kyle
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Installing Rational XDE v2002 Release 2.1 on a machine running WSAD5
 
Similar Threads
WSAD6.0
Which is the best IDE?
IBM WSAD 5.0
installing both WAS and WSAD and linking to DB2
IBM Rational XDE for Eclipse