File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
Win a copy of Soft Skills: The software developer's life manual this week in the Jobs Discussion forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Struts 1.1 + WSAD 5

 
Max Tomlinson
Ranch Hand
Posts: 365
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all-
I recall that earlier versions of WSAD5 (e.g. 5.0.1) had Struts beta 1.1 support. Now, with WSAD 5.1, it appears that the 1.1 jars are the 'real' thing. Is this true?
Also, what production version of WAS would I need to be running to support an EAR with a WAR created by WSAD 5.1?
thank you,
Max Tomlinson
 
Scott Duncan
Ranch Hand
Posts: 364
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I do not know if it is the 'real' thing or not but I use struts 1.1 with WSAD 5.1 without difficulty.
WAS 5 supports both 4.0 and 5.0 apps and WSAD 5.1 can be tested against either version of test server.
 
Max Tomlinson
Ranch Hand
Posts: 365
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OK, another WSAD5ish question:
If I develop a Struts WebApp on WSAD 5.1.x, will it deploy OK to WAS 5.0.2 in production? I ask becasue we have seen some compatibility issues between WSAD 5.0.x and WSAD 5.1.x.
Thank you,
Max
(BTW, yes i would like peanut)
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 33667
316
Eclipse IDE Java VI Editor
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The compatibility issues between WSAD 5.0 and WSAD 5.1 mainly stem from the way metadata in the workspace is stored. You can deploy to WAS 5.0 from either of them.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic