Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Attn.Kyle:Problem while configuring WPS with Sun One Directory Server!!

 
Ravi Kumar Ravuru
Ranch Hand
Posts: 176
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Kyle,
Iam configuring Websphere Portal Server for Sun One Directory Server with the instructions given in the following link:
http://pvcid.raleigh.ibm.com/wpf/ic/5021hp/smb/en/InfoCenter/wpf/cfg_sun_wp.html
I have entered the values which were instructed in the above link and running the following command
WPSconfig.bat validate-ldap
Iam getting the following error:
Running WebSphere Portal 5.0.0.0 configuration task.
MYLANG is en
E:\WebSphere\AppServer\java\bin\native2ascii ..\config\wpconfig.properties ..\co
nfig\wpconfig_ascii.properties
Setting cfg.file.name.original to wpconfig.properties
Setting cfg.file.name to wpconfig_ascii.properties
Buildfile: wpconfig.xml
validate-ldap:
action-validate-ldap-connection:
[ldapcheck] ###############################################################
[ldapcheck] ldapURL : 9.182.93.196:389
[ldapcheck] ldapUser : cn=Directory Manager
[ldapcheck] ldapPassword : *
[ldapcheck] ldapSslEnabled : false
[ldapcheck] ###############################################################
action-validate-ldap-suffix:
[ldapcheck] ###############################################################
[ldapcheck] ldapURL : 9.182.93.196:389
[ldapcheck] ldapUser : cn=Directory Manager
[ldapcheck] ldapPassword : *
[ldapcheck] ldapSslEnabled : false
[ldapcheck] objectDn : o=cognos,c=CA
[ldapcheck] ###############################################################
[ldapcheck] Checking for 'o=cognos,c=CA'
[ldapcheck] ###############################################################
action-validate-ldap-was-admin-user:
[ldapcheck] ###############################################################
[ldapcheck] ldapURL : 9.182.93.196:389
[ldapcheck] ldapUser : uid=cognos,o=cognos,c=CA
[ldapcheck] ldapPassword : *
[ldapcheck] ldapSslEnabled : false
[ldapcheck] javax.naming.AuthenticationException: [LDAP: error code 32 - No Such
Object]
[ldapcheck] ERROR: 4
[ldapcheck] Invalid or insufficient authorization privileges.
BUILD FAILED
E:\WebSphere\PortalServer\config\wpconfig.xml:359: ERROR: 4
Total time: 2 seconds

The user which was created in Sun One Directory Server is being used in WPconfig.properties.
Iam unable to trace where i went wrong.
Kindly suggest me the solution.
Regards,
Ravi
 
Ravi Kumar Ravuru
Ranch Hand
Posts: 176
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Kyle,
The above problem was solved.Iam getting problem while enabling Websphere Application Server Security for Single-sign on to LDAP(SUN One Directory Server) from Portal Server.
the command for enabling the security is
wpsconfig enable-security-ldap
iam following the link which was given in my previous post.
The error is as follows:
Licensed Materials - Property of IBM
5724-E76, 5724-E77
(C) Copyright IBM Corp. 2001, 2003 All Rights Reserved.
Running WebSphere Portal 5.0.0.0 configuration task.
MYLANG is en
E:\WebSphere\AppServer\java\bin\native2ascii ..\config\wpconfig.properties ..\config\wpconfig_ascii.properties
Setting cfg.file.name.original to wpconfig.properties
Setting cfg.file.name to wpconfig_ascii.properties
Buildfile: wpconfig.xml
Property "DbDriverDs" being trimmed of trailing blanks!
action-set-time-property:
init:
action-pre-process-wmm:
[logmsg] 2004.04.12 13:29:13.375 action-pre-process-wmm
[logmsg] EJPC3057I Updating Portal configuration
[logmsg]
[echo] Modifying WMM database_setenv.sh/.bat shell scripts
[echo] 2004-04-12-01-29
action-validate-was-instance:
[logmsg] 2004.04.12 13:29:14.484 action-validate-was-instance predicate
[logmsg] EJPC1019I Checking WebSphere Application Server at "E:/WebSphere/AppServer"
[logmsg]
[validationshell] 2004.04.12 13:29:17.891 Discovery validate_location
[validationshell] EJPC1518I Discovery processing discovered WebSphere Application Server installed at location "E:/WebSphere/AppServer" has framework component "BASE"
[validationshell]
[validationshell]
[validationshell] 2004.04.12 13:29:17.906 Discovery was_functor_for_path
[validationshell] EJPC1518I Discovery processing discovered WebSphere Application Server installed at location "E:/WebSphere/AppServer" has framework component "PME"
[validationshell]
[validationshell]
[validationshell] 2004.04.12 13:29:18.078 Discovery.rules disc_get_OS
[validationshell] EJPC1500I The Discovered Operating System type is "WIN"
[validationshell]
[validationshell]
action-log-validate-was-instance-success:
[logmsg] 2004.04.12 13:29:18.891 action-validate-was-instance predicate
[logmsg] EJPC1020I Check for WebSphere Application Server succeeded.
[logmsg]
action-update-xmlaccess-scripts:
action-update-migration-scripts:
init-cfg-files:
[logmsg] 2004.04.12 13:29:19.703 init-cfg-files
[logmsg] EJPC3076I Delete/make directory, Shorten path, Copy files and replace placeholder, set file permissions
[logmsg]
[delete] Deleting directory E:\WebSphere\PortalServer\config\work
[mkdir] Created dir: E:\WebSphere\PortalServer\config\work
[setproperty] Property NewDbLibrary was set to "E:/IBM/SQLLIB/java/db2java.zip";
[setproperty] Property UserSuffix was set to ou=people,o=cognos,c=CA
[setproperty] Property GroupSuffix was set to ou=groups,o=cognos,c=CA
[setproperty] Property WasUseridShort was set to wpsadmin
[setproperty] Property WmmConfig was set to 1
[generate-portalid] Generated portal ID: 00096B2500DB01131ADF
[copy] Copying 523 files to E:\WEBSPH~1\PORTAL~1\config\work
action-replace-tokens-cloudscape-setcpbat:
[logmsg] 2004.04.12 13:29:50.953 init-cfg-files
[logmsg] EJPC3078I Delete/make directory, Shorten path, Copy files and replace placeholder, set file permissions finished
[logmsg]
start-admin-server:
[logmsg] 2004.04.12 13:29:50.969 start-admin-server
[logmsg] EJPC3060I Starting Server "server1"
[logmsg]
[exec] ADMU0116I: Tool information is being logged in file
[exec] E:\WebSphere\AppServer\logs\server1\startServer.log
[exec] ADMU3100I: Reading configuration for server: server1
[exec] ADMU3027E: An instance of the server is already running: server1
[exec] ADMU0111E: Program exiting with error:
[exec] com.ibm.websphere.management.exception.AdminException: ADMU3027E: An
[exec] instance of the server is already running: server1
[exec] ADMU0211I: Error details may be seen in the file:
[exec] E:\WebSphere\AppServer\logs\server1\startServer.log
[exec] ADMU1211I: To obtain a full trace of the failure, use the -trace option.
action-check-was-uid:
[checkpropertyvalue] Property WasUserid was set to uid=wpsadmin,ou=people,o=cognos,c=CA
action-stop-portal-server-secure:
[logmsg] 2004.04.12 13:30:02.344 stop-portal-server-secure
[logmsg] EJPC3063I Stopping Server "WebSphere_Portal"
[logmsg]
[exec] ADMU0116I: Tool information is being logged in file
[exec] E:\WebSphere\AppServer\logs\WebSphere_Portal\stopServer.log
[exec] ADMU3100I: Reading configuration for server: WebSphere_Portal
[exec] ADMU3201I: Server stop request issued. Waiting for stop status.
[exec] ADMU4000I: Server WebSphere_Portal stop completed.
action-stop-portal-server-insecure:
stop-portal-server:
enable-security-ldap:
validate-ldap:
action-validate-ldap-connection:
[ldapcheck] ###############################################################
[ldapcheck] ldapURL : localhost:389
[ldapcheck] ldapUser : cn=Directory Manager
[ldapcheck] ldapPassword : *
[ldapcheck] ldapSslEnabled : false
[ldapcheck] ###############################################################
action-validate-ldap-suffix:
[ldapcheck] ###############################################################
[ldapcheck] ldapURL : localhost:389
[ldapcheck] ldapUser : cn=Directory Manager
[ldapcheck] ldapPassword : *
[ldapcheck] ldapSslEnabled : false
[ldapcheck] objectDn : o=cognos,c=CA
[ldapcheck] ###############################################################
[ldapcheck] Checking for 'o=cognos,c=CA'
[ldapcheck] ###############################################################
action-validate-ldap-was-admin-user:
[ldapcheck] ###############################################################
[ldapcheck] ldapURL : localhost:389
[ldapcheck] ldapUser : uid=wpsadmin,ou=people,o=cognos,c=CA
[ldapcheck] ldapPassword : *
[ldapcheck] ldapSslEnabled : false
[ldapcheck] ###############################################################
action-validate-ldap-portal-admin-user:
[ldapcheck] ###############################################################
[ldapcheck] ldapURL : localhost:389
[ldapcheck] ldapUser : uid=wpsadmin,ou=people,o=cognos,c=CA
[ldapcheck] ldapPassword : *
[ldapcheck] ldapSslEnabled : false
[ldapcheck] ###############################################################
action-validate-ldap-bind-user:
[ldapcheck] ###############################################################
[ldapcheck] ldapURL : localhost:389
[ldapcheck] ldapUser : uid=wpsbind,ou=people,o=cognos,c=CA
[ldapcheck] ldapPassword : *
[ldapcheck] ldapSslEnabled : false
[ldapcheck] ###############################################################
action-secure-portal-ldap:
action-is-lookaside:
[setproperty] Property WmmConfig was set to 1
action-set-time-property:
init:
action-pre-process-wmm:
[logmsg] 2004.04.12 13:31:15.625 action-pre-process-wmm
[logmsg] EJPC3057I Updating Portal configuration
[logmsg]
[echo] Modifying WMM database_setenv.sh/.bat shell scripts
[echo] 2004-04-12-01-29
action-validate-was-instance:
[logmsg] 2004.04.12 13:31:16.344 action-validate-was-instance predicate
[logmsg] EJPC1019I Checking WebSphere Application Server at "E:/WebSphere/AppServer"
[logmsg]
[validationshell] 2004.04.12 13:31:19.047 Discovery validate_location
[validationshell] EJPC1518I Discovery processing discovered WebSphere Application Server installed at location "E:/WebSphere/AppServer" has framework component "BASE"
[validationshell]
[validationshell]
[validationshell] 2004.04.12 13:31:19.234 Discovery was_functor_for_path
[validationshell] EJPC1518I Discovery processing discovered WebSphere Application Server installed at location "E:/WebSphere/AppServer" has framework component "PME"
[validationshell]
[validationshell]
[validationshell] 2004.04.12 13:31:19.344 Discovery.rules disc_get_OS
[validationshell] EJPC1500I The Discovered Operating System type is "WIN"
[validationshell]
[validationshell]
action-log-validate-was-instance-success:
[logmsg] 2004.04.12 13:31:20.078 action-validate-was-instance predicate
[logmsg] EJPC1020I Check for WebSphere Application Server succeeded.
[logmsg]
action-update-xmlaccess-scripts:
action-update-migration-scripts:
init-cfg-files:
[logmsg] 2004.04.12 13:31:20.641 init-cfg-files
[logmsg] EJPC3076I Delete/make directory, Shorten path, Copy files and replace placeholder, set file permissions
[logmsg]
[delete] Deleting directory E:\WebSphere\PortalServer\config\work
[mkdir] Created dir: E:\WebSphere\PortalServer\config\work
[setproperty] Property NewDbLibrary was set to "E:/IBM/SQLLIB/java/db2java.zip";
[setproperty] Property UserSuffix was set to ou=people,o=cognos,c=CA
[setproperty] Property GroupSuffix was set to ou=groups,o=cognos,c=CA
[setproperty] Property WasUseridShort was set to wpsadmin
[setproperty] Property WmmConfig was set to 1
[generate-portalid] Generated portal ID: 00096B2500DB01131AE1
[copy] Copying 523 files to E:\WEBSPH~1\PORTAL~1\config\work
action-replace-tokens-cloudscape-setcpbat:
[logmsg] 2004.04.12 13:31:48.078 init-cfg-files
[logmsg] EJPC3078I Delete/make directory, Shorten path, Copy files and replace placeholder, set file permissions finished
[logmsg]
action-init-database-wmm-lookaside:
action-switch-database:
action-update-database-wps-ldap:
[logmsg] 2004.04.12 13:31:48.453 action-update-database-wps-ldap
[logmsg] EJPC3068I Updating database "wps50"
[logmsg]
[java] Connected to jdbc b2:wps50;create=true
[java] Reading file E:\WebSphere\PortalServer\config\work\db\db2\wps_ldap.sql
[java] UPDATE user_desc SET name=LOWER('uid=wpsadmin,ou=people,o=cognos,c=CA') WHERE oid=10
[java]
[java] UPDATE user_desc SET name=LOWER('cn=wpsadmins,o=default organization') WHERE oid=11
[java]
[logmsg] 2004.04.12 13:32:02.094 action-update-database-wps-ldap
[logmsg] EJPC3009I Database "wps50" updated
[logmsg]
action-web-xml-old-exists:
action-create-web-xml-old:
action-update-web-xml:
[copy] Copying 1 file to E:\WebSphere\AppServer\installedApps\mars-blr\wps.ear\wps.war\WEB-INF
[copy] Copying 1 file to E:\WebSphere\AppServer\config\cells\mars-blr\applications\wps.ear\deployments\wps\wps.war\WEB-INF
action-update-wps-ear:
[logmsg] 2004.04.12 13:32:02.547 action-update-wps-ear
[logmsg] EJPC3057I Updating Portal configuration
[logmsg]
action-set-servlet-paths:
[logmsg] 2004.04.12 13:32:02.688 action-set-servlet-paths
[logmsg] EJPC3057I Updating Portal configuration
[logmsg]
action-update-configservice:
[logmsg] 2004.04.12 13:32:03.406 action-update-configservice
[logmsg] EJPC3057I Updating Portal configuration
[logmsg]
action-update-deploymentservice:
[logmsg] 2004.04.12 13:32:03.469 action-update-deploymentservice
[logmsg] EJPC3057I Updating Portal configuration
[logmsg]
action-update-datastoreservice:
[logmsg] 2004.04.12 13:32:03.531 action-update-datastoreservice
[logmsg] EJPC3057I Updating Portal configuration
[logmsg]
action-update-vaultservice-ldap:
[logmsg] 2004.04.12 13:32:03.547 action-update-vaultservice
[logmsg] EJPC3057I Updating Portal configuration
[logmsg]
action-is-lookaside:
[setproperty] Property WmmConfig was set to 1
action-update-wmm-ldap:
[logmsg] 2004.04.12 13:32:03.594 atcion-update-wmm-ldap
[logmsg] EJPC3057I Updating Portal configuration
[logmsg]
[copy] Copying 1 file to E:\WebSphere\PortalServer\shared\app\wmm
[copy] Copying 1 file to E:\WebSphere\PortalServer\wmm
action-config-portal-ldap:
[logmsg] 2004.04.12 13:32:03.891 action-config-portal-ldap
[logmsg] RAS0001E: Message key Config.portal.ldap.success was not found in the message file com.ibm.wps.config.logging.InstallAndConfigLogger.
[logmsg]
action-secure-configservice:
[logmsg] 2004.04.12 13:32:04.266 action-secure-configservice
[logmsg] EJPC3057I Updating Portal configuration
[logmsg]
action-update-java-policy:
[logmsg] 2004.04.12 13:32:04.656 action-update-java-policy
[logmsg] EJPC3057I Updating Portal configuration
[logmsg]
[copy] Copying 1 file to E:\WebSphere\AppServer\config\cells\mars-blr\nodes\mars-blr
action-cfg-was-security-ldap:
[logmsg] 2004.04.12 13:32:04.953 action-cfg-was-security-ldap
[logmsg] EJPC3048I Configuring security with LDAP
[logmsg]
[wsadmin] WASX7209I: Connected to process "server1" on node mars-blr using SOAP connector; The type of process is: UnManagedProcess
[wsadmin] ===== in configLTPA
[wsadmin] LTPA keys was generated
[wsadmin]
[wsadmin] public, private, and shared keys exported
[wsadmin]
[wsadmin] ===== in configLDAP
[wsadmin] Removed hostId (cells/mars-blr:security.xml#EndPoint_1)
[wsadmin]
[wsadmin] Saved the change
[wsadmin]
[wsadmin] LDAP configured
[wsadmin] ===== in configAdvancedLDAP
[wsadmin] ===== in createJAASAuthDataPortal
[wsadmin] JAAS alias: mars-blr/wpsldap
[wsadmin] Delete the JAASAuthData for the given alias mars-blr/wpsldap, if exist...
[wsadmin] Create the new object mars-blr/wpsldap
[wsadmin] ===== in createJAASConfigEntry
[wsadmin] appLoginConfigId=(cells/mars-blr:security.xml#JAASConfiguration_1)
[wsadmin]
[wsadmin] This alias is already defined.
[wsadmin] ===== in createJAASConfigEntry
[wsadmin] appLoginConfigId=(cells/mars-blr:security.xml#JAASConfiguration_1)
[wsadmin]
[wsadmin] This alias is already defined.
[wsadmin] ===== in configGlobalSecurity
[wsadmin] inputauthmech is LTPA ####### authmech is (cells/mars-blr:security.xml#SWAMAuthentication_1)
[wsadmin] inputauthmech is LTPA ####### authmech is (cells/mars-blr:security.xml#LTPA_1)
[wsadmin] setting the authentication mechanism to (cells/mars-blr:security.xml#LTPA_1)
[wsadmin] ===== validate security settings
[wsadmin] cachetimeout value is 600
[wsadmin] cachetimeout value is ok
[wsadmin] Active Authentication Mechanism is (cells/mars-blr:security.xml#LTPA_1)
[wsadmin] Active User Registry is (cells/mars-blr:security.xml#LDAPUserRegistry_1)
[wsadmin] Authmech is LTPA
[wsadmin]
[wsadmin]
[wsadmin] Validation success. Configuration saved.
[logmsg] 2004.04.12 13:34:12.266 action-cfg-was-security-ldap
[logmsg] EJPC3050I Security configured with LDAP
[logmsg]
start-portal-server:
[logmsg] 2004.04.12 13:34:12.656 start-portal-server
[logmsg] EJPC3060I Starting Server "WebSphere_Portal"
[logmsg]
[exec] ADMU0116I: Tool information is being logged in file
[exec] E:\WebSphere\AppServer\logs\WebSphere_Portal\startServer.log
[exec] ADMU3100I: Reading configuration for server: WebSphere_Portal
[exec] ADMU3200I: Server launched. Waiting for initialization status.
[exec] ADMU3000I: Server WebSphere_Portal open for e-business; process id is 3216
action-create-deployment-credentials:
[xmlaccess] XMLA0006I: Connecting to URL http://localhost:9081/wps/config
[xmlaccess] XMLA0002I: Reading input file E:\WebSphere\PortalServer\config\work\createDeploymentCredentials.xml
[xmlaccess] XMLA0011I: Request accepted
[xmlaccess] <?xml version="1.0"?>
[xmlaccess] <failure>
[xmlaccess] com.ibm.wps.command.MissingAccessRightsException: WPCM0006E:XmlCommand: Missing access rights.
[xmlaccess] </failure>
BUILD FAILED
E:\WebSphere\PortalServer\config\wpconfig.xml:266: XMLA0015E: Server response indicates an error
Total time: 8 minutes 25 seconds
Pls help me out.
Regards,
Ravi
 
Praveena Jayanthi
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ravi,

How did you solve your MissingAccessRights problem while enabling security on WPS and using sunone LDAP?

-Praveena
 
Brian Wright
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've encountered that precise error recently. In our case, it occurred because we'd setup LDAP over SSL and in the process had to edit the 'wmm.xml' file. I realise you're not running your LDAP over SSL, but take a look at the PORTAL_ROOT/wmm/wmm.xml file - it actually recreates that file as part of the 'enable-ldap-security' configuration task, along with a few other files.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic