Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

What setting are required to run jsp on WSAD

 
Satya Komirisetti
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi ,I am new to jsp ,doing in WSAD.I trying to run simple code
<%@ page language="java" %>
<%! int i,j;%>
<% for( i = 0,j=10;i<=j;i++) { %>
<%= i %>
<% } %>
no compile time errors and when running on browser,whole code is dumping.Do i require to set something somewhere?if so,how?Is there any procedure to follow?
thanks
[ April 23, 2004: Message edited by: Satya Komirosetti ]
 
Nathan Pruett
Bartender
Posts: 4121
IntelliJ IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What does "whole code is dumping" mean? Are you getting an exception, or are you seeing your JSP code displayed in the browser instead of the results of the code?
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34391
346
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Satya,
Are you trying to run in debug mode or regular mode? If debug mode, try in regular mode because less errors occur that way.
 
Satya Komirisetti
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
no compile time errors,no exceptions,no run time errors .Inthe browser Jsp code is displayed instead of result.
I am running in regular mode only.
Thank you
[ April 28, 2004: Message edited by: Satya Komirosetti ]
 
Nathan Pruett
Bartender
Posts: 4121
IntelliJ IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is the version of WebSphere you are using pretty recent? If it's using JSP 2.0 check the web.xml file for any usage of "<scripting-invalid>true</scripting-invalid>"
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64827
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Since this is Websphere-specific, I'm moving this off to the Websphere Forum for further discussion.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic