This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Websphere and the fly likes Debugger won't Step Into Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Debugger won Watch "Debugger won New topic
Author

Debugger won't Step Into

Michael Morris
Ranch Hand

Joined: Jan 30, 2002
Posts: 3451
I am having trouble with WSAD stepping into certain classes. The classes in question are in a jar which is part of our infrastructure. Ordinarily when you step into a jar class you get the source not available window with the option to attach the source. On these classes it just steps over. The step into works fine on other jars. Does anyone have any ideas on this?


Any intelligent fool can make things bigger, more complex, and more violent. It takes a touch of genius - and a lot of courage - to move in the opposite direction. - Ernst F. Schumacher
Jeanne Boyarsky
internet detective
Marshal

Joined: May 26, 2003
Posts: 30136
    
150

Michael,
Try checking to see if the jar file is already associated with [non-existant] source code. If so, delete it and you should get the prompt again. (you may have to restart the server or wsad) You can check this in the build properties for the project.
Also, what version of WSAD are you using?


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
 
 
subject: Debugger won't Step Into
 
Similar Threads
Unable to load lookAnd feel Jar for my java Swing Application Help Please
How to see the java documentation for a method in a class which is inside a jar file?
Spring Related-- @Autowired with Map<String, myObjectType> is not initialized in the IoC container
problem in Create jar
an unbelievable question about import!!!