This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Websphere and the fly likes Problem while creating WebService in WSAD 5.1.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Problem while creating WebService in WSAD 5.1.1" Watch "Problem while creating WebService in WSAD 5.1.1" New topic
Author

Problem while creating WebService in WSAD 5.1.1

pjoisha
Ranch Hand

Joined: Mar 06, 2001
Posts: 123
I have a EJB that exposes one service which happens to return
an org.w3c.dom.Element data type something like this

public org.w3c.dom.Element sayHello() throws java.rmi.RemoteException;


Now when i try to generate my Web Service via the Web Services Wizard
I get a "Error in generating WSDL file from Java" error

Sequence of steps I followed:

(1) New->Other->Web Services-Web Service
(2) Selected "EJB Web Service" as the "Web service Type"
(3) Left only "Overwrite files without warning"
and "Create folders when necessary" checked
(4) In the "Service Deployment Configuration" pane
I have the EJB project and Router project populated
(5) In the "Web Service EJB Selection Pane"
I have ensured the following are populated
JNDI provider URL,
JNDI initial context factory,
EJB JNDI name,
EJB Home interface class name,
EJB remote interface class name

Left "use an existing service endpoint interface" unchecked

Selected "SOAP over HTTP" transport

(6) In the "Web Service Java Bean Identity" pane
I leave my only method selected and I leave "Document/Literal"
as the Style and Use checked

Security configuration is set to "No Security"

At this point I get an error when I click "next"

IWAB0398E Error in generating WSDL file from Java

In Details ->

WSWS3324E: Error: Problems encountered trying to write schema for
org.w3c.dom.Element; nested exception is:
java.lang.NullPointerException

This creation worked in WSAD 5.0.2 and after upgrading we are
facing with this problem.

Thanks in advance

PJ
[ July 16, 2004: Message edited by: Prashanth Joisha ]
saikiran surya
Greenhorn

Joined: Jun 04, 2004
Posts: 16
Hi,

Even we are having the same problem. did you happen to have the fix for this?

Thanks,
ss
kapil munjal
Ranch Hand

Joined: May 11, 2004
Posts: 298
Hi,

I am facing the same problem...are you able to get the solution to this.

Kapil


Kapil Munjal
SCJP 1.4, SCWCD 1.4
Kosala Amarasinghe
Greenhorn

Joined: May 20, 2011
Posts: 3

I tried a simple restart of WSAD and rebuild and that worked for me.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: Problem while creating WebService in WSAD 5.1.1
 
Similar Threads
Sample Questions for 288 - Need answers
Webservice and remote ejbs
IBM Exam 157 - Questions and Answers (Sample Exam)
Urgent Help Required org.w3c.dom.Element
Repost - Error creating WebService in WSAD 5.1.1 - Kyle could you pls help me here