File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Websphere and the fly likes class file has wrong version 48.0, should be 47.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "class file has wrong version 48.0, should be 47.0" Watch "class file has wrong version 48.0, should be 47.0" New topic
Author

class file has wrong version 48.0, should be 47.0

Rob Mitchell
Greenhorn

Joined: Dec 10, 2003
Posts: 7
Using WSAD 5.1.2 on Windows XP. I create simple Dynamic web project with one Java class (that compiles cleanly) and one JSP (that doesn't). The JSP has scriplet for the Java class and the Project Preferences as well as Window Preferences are both set for 1.4 Compliance.

If I change either Project Preference or Window > Preferences to use 1.3 JDK Compliance or use 1.4 but set Generated .class files compatibility to 1.3 then the JSP compiles cleanly.

Any ideas?

Yes, I did have a 1.3.1 JDK in my PATH environment variable, but then I created a JAVA_HOME to the IBM WSAD/Eclipse Java directory and prepended that to the PATH env variable and restarted machine.

Thanks!

Rob Mitchell
Rob.Mitchell@comcast.net


_ ____________________________ _ <br />Rob Mitchell<br />Base Class Technologies, Inc.<br />Java, WebSphere, Domino, Oracle, Web development<br />Rob.Mitchell@comcast.net
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: class file has wrong version 48.0, should be 47.0
 
Similar Threads
Eclipse 3.1 with JDK 1.5
Struts 2 -- Unsupported major.minor version issue
WSAD 5.1.2 and J2SE 1.5 Compiler
How to pass -source 1.4 argument in Eclipse
compareToIgnoreCase() problem