aspose file tools*
The moose likes Websphere and the fly likes Disabling JCA connection pooling on WAS5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Disabling JCA connection pooling on WAS5" Watch "Disabling JCA connection pooling on WAS5" New topic
Author

Disabling JCA connection pooling on WAS5

Mikkel Lauritsen
Greenhorn

Joined: Sep 17, 2004
Posts: 1
Hi all,

a hopefully simple question: is there any way to declaratively disable
connection pooling for a JCA based data source in WAS 5.1?

Just to give some background, I'm debugging an app that talks to a
backend system through a homegrown JCA resource adapter. I'm seeing
problems that look as if the backend system gets confused from receiving
more than one request on the same connection, so I would like to try to
force WebSphere to not pool the connections.

I have been digging through the InfoCenter and various RedBooks, but I
have been unable to find any information on whether I can somehow confi-
gure a connection factory to not do pooling. My hope is to avoid having
to rewrite the code that opens the connections, and if the problem is
later fixed I will be able to just reenable pooling.

Best regards,
Mikkel Lauritsen
Steve Wink
Ranch Hand

Joined: May 13, 2002
Posts: 223
Originally posted by Mikkel Lauritsen:
Hi all,

a hopefully simple question: is there any way to declaratively disable
connection pooling for a JCA based data source in WAS 5.1?

Just to give some background, I'm debugging an app that talks to a
backend system through a homegrown JCA resource adapter. I'm seeing
problems that look as if the backend system gets confused from receiving
more than one request on the same connection, so I would like to try to
force WebSphere to not pool the connections.

I have been digging through the InfoCenter and various RedBooks, but I
have been unable to find any information on whether I can somehow confi-
gure a connection factory to not do pooling. My hope is to avoid having
to rewrite the code that opens the connections, and if the problem is
later fixed I will be able to just reenable pooling.

Best regards,
Mikkel Lauritsen



I don't know the exact answer to your question, but may have a work around. Since your JCA adapter is your own, can't you have a singleton backending the connections, so that all connections from the same pool end up with this one object that talks to your legacy system. Would this work?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Disabling JCA connection pooling on WAS5