*
The moose likes Websphere and the fly likes WAS 5.0 initialcontext calls never return for RMI client app Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "WAS 5.0 initialcontext calls never return for RMI client app" Watch "WAS 5.0 initialcontext calls never return for RMI client app" New topic
Author

WAS 5.0 initialcontext calls never return for RMI client app

Joe Kemp
Greenhorn

Joined: Oct 15, 2004
Posts: 1
I am trying to make a client app connect to a EJB on a WAS 5.0 server. I am using a RMI/IIOP connection. Any call that attempts to access these components fails to return. For instance, a initialcontext.lookup can be called but will never return. Same with a listbindings. If I try to list the bindings in the cell area it fails to return.

This only occurs on our production servers. They are setup in a cluster. The same application on our test server (same OS and WAS) works fine. I can instantiate the EJBs and use them as designed. No exceptions are thrown and I can't find any reference to these connections in any WAS log files. I am using WSAD with a IBM JDK.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: WAS 5.0 initialcontext calls never return for RMI client app
 
Similar Threads
Thank you group - 141/155
RMI version problem
Lockmanger- singleton implementation /static creation & assignment in RMI server ?
Db2 datasource setup on WAS 5.0
Excluding existing code from custom JAAS login module