aspose file tools*
The moose likes Websphere and the fly likes WAS Classpath Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "WAS Classpath" Watch "WAS Classpath" New topic
Author

WAS Classpath

Alfredo Porras
Greenhorn

Joined: May 07, 2004
Posts: 4
Hello everybody. I'm experiencing some trouble with a application that I have running on WAS 5.1 on SunOs 5.8. It was running perfectly fine and all of the sudden I started getting the following error:

Unresolved compilation problems:
The import javax.crypto cannot be resolved
The import javax.crypto cannot be resolved
The import com.sun.crypto cannot be resolved

and so on for several other clases and packages. I already checked and all the classes and packages are where they are suppose to be in the WAS home directory /java/jre/lib/ext. I'm afraid something we did on the machine might have change an environment variable. I have already tried adding some lines to the profile of the user we use to start WAS and add the path to this libraries in the CLASSPATH environment variable but it was to no avail. Any idea what might be wrong?, what other variables should I check?. How do I know from which directory is WAS taking java to compile the files?. Thanks in advance.

Rigel Porras
David Ulicny
Ranch Hand

Joined: Aug 04, 2004
Posts: 724
I solve this problem only for Windows and iSeries, so you have to add it to the PATH variable.


SCJP<br />SCWCD <br />ICSD(286)<br />MCP 70-216
Alfredo Porras
Greenhorn

Joined: May 07, 2004
Posts: 4
David, thanks for you answer but I already tried it and it didn't work. The funny part about all this, is that according to me the AppServer is not supposed to be trying to compile stuff anymore. This class where I'm getting all the errors is in a jar that I have as a shared library. Of course all that there is inside the jar is only .class files, so it should not be trying to compile it again. I'm using exactly the same jar in a similar server with the same operating system and everything works just fine.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: WAS Classpath