*
The moose likes Websphere and the fly likes How can I upgrade Eclipse SDK for WSAD 5.1.2? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "How can I upgrade Eclipse SDK for WSAD 5.1.2?" Watch "How can I upgrade Eclipse SDK for WSAD 5.1.2?" New topic
Author

How can I upgrade Eclipse SDK for WSAD 5.1.2?

Haricharan Maramraj
Greenhorn

Joined: Dec 19, 2004
Posts: 6
Hi:

I am currently using WSAD 5.1.2 and I would like to upgrade Eclipse SDK from 2.x.x to 3.0.1. Could anyone tell me how I can do that? I already tried by downloading the new version of Eclipse SDK into WSAD installed directory but it throws an error log while opening studio. The error stack is as follows:

!SESSION Jan 18, 2005 15:00:18.671 ---------------------------------------------
eclipse.buildId=M200409161125
java.fullversion=J2RE 1.3.1 IBM J9 build 20031201 (JIT enabled)
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

!ENTRY org.eclipse.osgi Jan 18, 2005 15:00:18.671
!MESSAGE Error registering XML parser services.
!STACK 0
java.lang.ClassNotFoundException: javax.xml.parsers.SAXParserFactory
at java.lang.Throwable.<init>(Throwable.java:52)
at java.lang.Throwable.<init>(Throwable.java:66)
at java.lang.ClassNotFoundException.<init>(ClassNotFoundException.java:79)
at java.lang.Class.forName(Class.java:116)
at org.eclipse.core.runtime.adaptor.EclipseAdaptor.registerEndorsedXMLParser(EclipseAdaptor.java:272)
at org.eclipse.core.runtime.adaptor.EclipseAdaptor.frameworkStart(EclipseAdaptor.java:253)
at org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:61)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:958)
at java.security.AccessController.doPrivileged(AccessController.java:189)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:954)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:937)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:553)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:477)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:273)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.launch(StartLevelManager.java:243)
at org.eclipse.osgi.framework.internal.core.SystemBundle.resume(SystemBundle.java:166)
at org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:425)
at org.eclipse.osgi.framework.internal.core.OSGi.launch(OSGi.java:51)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:216)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:127)
at java.lang.reflect.AccessibleObject.invokeL(AccessibleObject.java:207)
at java.lang.reflect.Method.invoke(Method.java:271)
at org.eclipse.core.launcher.Main.basicRun(Main.java:185)
at org.eclipse.core.launcher.Main.run(Main.java:704)
at org.eclipse.core.launcher.Main.main(Main.java:688)

!ENTRY org.eclipse.osgi Jan 18, 2005 15:00:18.859
!MESSAGE Startup error
!STACK 1
java.lang.NoClassDefFoundError: org.xml.sax.helpers.DefaultHandler
at java.lang.Throwable.<init>(Throwable.java:52)
at java.lang.Throwable.<init>(Throwable.java:66)
at java.lang.NoClassDefFoundError.<init>(NoClassDefFoundError.java:57)
at java.lang.ClassLoader.defineClassImpl(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:204)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:133)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:320)
at java.net.URLClassLoader.access$400(URLClassLoader.java:93)
at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:678)
at java.security.AccessController.doPrivileged(AccessController.java:218)
at java.net.URLClassLoader.findClass(URLClassLoader.java:239)
at java.lang.ClassLoader.loadClass(ClassLoader.java:594)
at java.lang.ClassLoader.loadClass(ClassLoader.java:553)
at org.eclipse.core.runtime.adaptor.PluginConverterImpl.parsePluginInfo(PluginConverterImpl.java:557)
at org.eclipse.core.runtime.adaptor.PluginConverterImpl.fillPluginInfo(PluginConverterImpl.java:111)
at org.eclipse.core.runtime.adaptor.PluginConverterImpl.convertManifest(PluginConverterImpl.java:660)
at org.eclipse.core.runtime.adaptor.EclipseBundleData.generateManifest(EclipseBundleData.java:233)
at org.eclipse.core.runtime.adaptor.EclipseBundleData.loadManifest(EclipseBundleData.java:191)
at org.eclipse.core.runtime.adaptor.EclipseBundleData.getManifest(EclipseBundleData.java:159)
at org.eclipse.core.runtime.adaptor.EclipseBundleData.loadFromManifest(EclipseBundleData.java:280)
at org.eclipse.osgi.framework.internal.defaultadaptor.DefaultBundleData.initializeNewBundle(DefaultBundleData.java:77)
at org.eclipse.osgi.framework.internal.defaultadaptor.DefaultAdaptor$1.begin(DefaultAdaptor.java:451)
at org.eclipse.osgi.framework.internal.core.Framework.installWorkerPrivileged(Framework.java:746)
at org.eclipse.osgi.framework.internal.core.Framework$2.run(Framework.java:664)
at java.security.AccessController.doPrivileged(AccessController.java:189)
at org.eclipse.osgi.framework.internal.core.Framework.installWorker(Framework.java:715)
at org.eclipse.osgi.framework.internal.core.Framework.installBundle(Framework.java:659)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.installBundle(BundleContextImpl.java:219)
at org.eclipse.core.runtime.adaptor.EclipseStarter.installBundles(EclipseStarter.java:800)
at org.eclipse.core.runtime.adaptor.EclipseStarter.loadBasicBundles(EclipseStarter.java:429)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:222)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:127)
at java.lang.reflect.AccessibleObject.invokeL(AccessibleObject.java:207)
at java.lang.reflect.Method.invoke(Method.java:271)
at org.eclipse.core.launcher.Main.basicRun(Main.java:185)
at org.eclipse.core.launcher.Main.run(Main.java:704)
at org.eclipse.core.launcher.Main.main(Main.java:688)

!ENTRY org.eclipse.osgi Jan 18, 2005 15:00:18.921
!MESSAGE Bundle initial@reference:file:e:/IBM/WSSAD5.1.2/eclipse/plugins/org.eclipse.core.runtime_3.0.1/ [1] was not resolved.

I really appreciate your help. Unfortunately, I could never get my questions answered in this forum. I hope someone spares his time to look at my question.
Roland Barcia
author
Ranch Hand

Joined: Apr 15, 2004
Posts: 181
WSAD 512 does not support Eclipse 3. Version 6 is based on Eclipse 3 and its called Rational Applicaiton Developer.


Roland Barcia: IBM Distinguished Engineer, CTO Mobile for Lab Services
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: How can I upgrade Eclipse SDK for WSAD 5.1.2?
 
Similar Threads
Trouble when Opening Eclipse
trouble installing and running eclipse
eclipse errors
Error in starting Eclipse 3.0.
Eclipse