my dog learned polymorphism*
The moose likes Websphere and the fly likes Upgrading from WAS 4.0 to 5.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Upgrading from WAS 4.0 to 5.1 " Watch "Upgrading from WAS 4.0 to 5.1 " New topic
Author

Upgrading from WAS 4.0 to 5.1

kalpana Kumar
Ranch Hand

Joined: Jul 03, 2003
Posts: 65
Hi all,
I need to know what kind of code changes are to be done while application is being migrated from WAS 4.0 to 5.1.
I appreciate Suggestions.
WAS 4.0 uses jdk 1.2 and j2ee 1.2
WAS 5.1 uses jdk 1.4 and j2ee 1.3.
We are using the Migrating tool provided by IBM. But as a developer what code changes should be done.
I know I have to take care of the assert keyword. I really appreciate of any documents or links.

Thanks
Jim Hicks
Greenhorn

Joined: Jun 23, 2004
Posts: 11
I am also working on upgrading from 4.0 to 5.1. The apps we have converted so far have converted with little problem. The new JSP compiler rejects tags that do not have proper ends. In the previous version you could leave some end tags off. I had one app in which the programer had been lazy and not done this.

We setup our http server to use the version 5 plugin so we can map apps to either the version 5.1 app server or the 4.0 app server. This allows us to migrate the apps as we have time.
 
Don't get me started about those stupid light bulbs.
 
subject: Upgrading from WAS 4.0 to 5.1