File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Websphere and the fly likes WAS 4.0 installation guide not on the web Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "WAS 4.0 installation guide not on the web" Watch "WAS 4.0 installation guide not on the web" New topic
Author

WAS 4.0 installation guide not on the web

Me Fdo
Ranch Hand

Joined: Jan 12, 2004
Posts: 33
I am new to WAS and going to build WAS4.0 base version no clustered version.

Cannot find any redbook on 4.0 .
Can anyone direct me to a place where I can get step by step installation including DB2 please!!
Makarand Parab
Ranch Hand

Joined: Dec 10, 2004
Posts: 121
Hi
Plz try out this link. This may help u
http://www-1.ibm.com/support/docview.wss?rs=0&q1=%2bredbooks+%2bon+%2bwas4.0&uid=swg27002349&loc=en_US&cs=utf-8&cc=us&lang=all

Hope u get what u want. Don't be angry be cool like ice.

Regards
Makarand Parab
Me Fdo
Ranch Hand

Joined: Jan 12, 2004
Posts: 33
Thanks for that!!

But I still cannot figureout where is the datasource is being created ..

Can someone give some pointers to the following error I get when launching the admin console.
--------------------


[05.01.28 17:53:13:469 CST] 2aa5675b DBMgr F SMTL0026E: Failure to create a data source: COM.ibm.db2.jdbc.DB2Exception: [IBM][CLI Driver] SQL1031N The database directory cannot be found on the indicated file system. SQLSTATE=58031

at COM.ibm.db2.jdbc.app.SQLExceptionGenerator.throw_SQLException(Unknown Source)
at COM.ibm.db2.jdbc.app.SQLExceptionGenerator.check_return_code(Unknown Source)
at COM.ibm.db2.jdbc.app.DB2Connection.connect(Unknown Source)
at COM.ibm.db2.jdbc.app.DB2Connection.<init>(Unknown Source)
at COM.ibm.db2.jdbc.app.DB2ReusableConnection.<init>(Unknown Source)
at COM.ibm.db2.jdbc.DB2PooledConnection.getConnection(Unknown Source)
at com.ibm.ejs.cm.pool.ConnectO.<init>(ConnectO.java:85)
at com.ibm.ejs.cm.pool.JDBC1xConnectionFactory.createConnection(JDBC1xConnectionFactory.java:42)
at com.ibm.ejs.cm.pool.ConnectionPool.createConnection(ConnectionPool.java:914)
at com.ibm.ejs.cm.pool.ConnectionPool.createOrWaitForConnection(ConnectionPool.java:846)
at com.ibm.ejs.cm.pool.ConnectionPool.findFreeConnection(ConnectionPool.java:764)
at com.ibm.ejs.cm.pool.ConnectionPool.findConnectionForTx(ConnectionPool.java:676)
at com.ibm.ejs.cm.pool.ConnectionPool.allocateConnection(ConnectionPool.java:610)
at com.ibm.ejs.cm.pool.ConnectionPool.getConnection(ConnectionPool.java:274)
at com.ibm.ejs.cm.pool.ConnectionPool.getConnection(ConnectionPool.java:269)
at com.ibm.ejs.cm.DataSourceImpl.getConnection(DataSourceImpl.java:99)
at com.ibm.ejs.sm.util.db.DBMgr.initialize(DBMgr.java:206)
at com.ibm.ejs.sm.server.AdminServer.initializeConnectionManager(AdminServer.java:1135)
at com.ibm.ws.runtime.Server.initializeRuntime0(Server.java:943)
at com.ibm.ejs.sm.server.ManagedServer.initializeRuntime0(ManagedServer.java:407)
at com.ibm.ejs.sm.server.AdminServer.initializeRuntime0(AdminServer.java:1104)
at com.ibm.ws.runtime.Server.initializeRuntime(Server.java:882)
at com.ibm.ejs.sm.server.AdminServer.main(AdminServer.java:391)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:158)
Makarand Parab
Ranch Hand

Joined: Dec 10, 2004
Posts: 121
Hi Me Fdo
Well let me guess what ur trying to do. ur trying to create datasource on WAS for DB2 database. Now i am sure that ur db2 database is not on the m/c where WAS is installed. If this is so just check u have the proper jar in the classpath.
Now lets say if i had oracle as Database, classes12.jar shd be there in the classpath. So for db2 there must be a jar which is needed in the classpath. Once that is done i am sure ur problem will be solved.
Even if u have Database on same m/c u will face same problem.

Regards
Makarand Parab
Me Fdo
Ranch Hand

Joined: Jan 12, 2004
Posts: 33
I have both WAS5.0 and WAS4.0 installed with DB2 8 in the same machine.

I believe DB2 equivalent to classes12.jar is db2jcc.jar

I have all the below in my class path(added JDBC 2.0 driver too)

C:\PROGRA~1\IBM\SQLLIB\java\db2jcc.jar;
C:\PROGRA~1\IBM\SQLLIB\java\sqlj.zip;
C:\PROGRA~1\IBM\SQLLIB\java\db2jcc_license_
cu.jar;
C:\PROGRA~1\IBM\SQLLIB\bin;
C:\PROGRA~1\IBM\SQLLIB\java\common.jar;
C:\Program Files\JavaSoft\JRE\1.3\lib\ext\jdbc2_0-stdext.jar

Here's what I did to install WAS4.0
1) Installed DB2 8.0
2) installed WAS
3) Launch the Admin console
4) Above error reported in WAS logs

Can you please let me know what should be there in the classpath related WAS?

Here's all i have in my classpath from the installer::

C:\Program Files\IBM\WebSphere Studio\bin\eglbatchgen.jar
Me Fdo
Ranch Hand

Joined: Jan 12, 2004
Posts: 33
Hi all

Resolutin for the problem I described above is below

The reason for my prior error was DBCreate script in WAS-HOME/bin did not run due to insufficient access rights.

I ran the DBCreate script manually by login db2admin id. All set!!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: WAS 4.0 installation guide not on the web
 
Similar Threads
How can i install Websphere
Installing VAJ on Windows XP
username and Password for Jboss JMX console
The tomcat which is used by myself is Tomcat Version 4.0-m5 ,but---
Doubt in static import