File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Websphere and the fly likes Login ID and Password for WebSphere admin console Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Java Interview Guide this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Login ID and Password for WebSphere admin console" Watch "Login ID and Password for WebSphere admin console" New topic

Login ID and Password for WebSphere admin console

Sandeep Papudesi

Joined: Feb 11, 2004
Posts: 10
Hi All,

I am using WAS 5.0.2 and Websphere Portal Server In portal server if I type the URL http://localhost:9081/admin the admin console of WAS is exposed to all the users. I want to block the admin console by specifying a user id and password.

I have enabled the Global Security option in WAS. It works fine and I am able to login to WAS using user id and password. But the problem is when I type the URL https://localhost:9444/wps/myportal it is taking me to Login Screen but once I give user id and password it is giving me the blank screen. If I disable the gloabal security option it is working fine.

Pls help me!!!. I have refered so many posts but I am not able to find a solution.

Sandeep Papudesi
Ravi Yalamanchili

Joined: Jan 14, 2006
Posts: 2

I guess when global security is enabled, it is better to give the fully qualified host name instead of localhost. Let me know if you have found any solution for this issue.



Thanks<br /> <br />Ravi
Venkat Yetrintala

Joined: Jul 18, 2005
Posts: 12
Hi Ravi Yalamanchili.,

I guess without qualified name, even localhost it can work.
if Iam wrong please let me know
Venkat Yetrintala
Brian Wright

Joined: Dec 12, 2005
Posts: 11
May I suggest that a likely problem is user authority to access the default Portal page/portlets? Try this:

Disable global security.

Ensure that the userid you're going to use to access Portal has authority to view/administer the portlets/Portal Applications you want available - note that this is the authorization within Portal itself, nothing to do with WAS!

Re-enable global security and test.

Good luck!
Pat Flickner
Ranch Hand

Joined: Nov 17, 2003
Posts: 173
1. Create a dummy user on your machine:
a. Open up Control Panel
b. Double-click User Accounts icon
c. Click the Advanced tab
d. Click the Advanced button under Advanced user management
e. Right-click Users and select New User
f. Fill in the userid information and click Create

(Note: I recommend un-clicking User must change password and then click Password never expires).

2. Now, back in Control Panel, double-click the Administrative Tools icon
3. Double-click Local Security Policy
4. Open up Local Policies
5. Double-click Act as part of the operating system
6. Click Add User or Group
7. Click Locations and select your computer name, then click OK
8. Now you may either enter the username you created and click the Check Names button and then click OK�
9. �OR click the Advanced button, click the Find Now button, and select the name from there and click OK, which will fill in the screen exactly as above, then click OK again.
10. Click OK back to the Local Security Policies screen, then log off and back on.
11. In WSAD under Servers, double-click either the localhost.wsi (or whatever you called your local server) or double-click the localhost under Servers in the Server Configuration
12. Select the Security tab along the bottom, click the checkbox next to Enable Security (Not supported on Windows 98 and Windows ME), and enter the userid you created in the Server ID box and the password. Save it and start up the server.
13. Now select the Ports tab and make sure that port 9443 has Enable SSL set to true:
14. Now, if you want to use SSL, use https://localhost:9443/ instead of http://localhost:9080.
I agree. Here's the link:
subject: Login ID and Password for WebSphere admin console
It's not a secret anymore!