aspose file tools*
The moose likes Websphere and the fly likes WSAD 5.1.2 and J2SE 1.5 Compiler Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "WSAD 5.1.2 and J2SE 1.5 Compiler" Watch "WSAD 5.1.2 and J2SE 1.5 Compiler" New topic
Author

WSAD 5.1.2 and J2SE 1.5 Compiler

Theodore Velkoff
Greenhorn

Joined: Jun 15, 2005
Posts: 1
Does anyone know if WebSphere Studio 5.1.2 can be used with the 1.5 compiler? I know how to set the JRE to my J2SE 1.5. But when to tell WebSphere which compiler version to use, the only choices are 1.3 and 1.4. (Window->Preferences->Java->Compiler->Compliance and Classfiles: Compiler Compliance Level)
Jeanne Boyarsky
author & internet detective
Marshal

Joined: May 26, 2003
Posts: 30973
    
159

Theodore,
WSAD 5.1 doesn't support Java 1.5. It's more than just pointing to a different compiler since there are new keywords.


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
Amirr Rafique
Ranch Hand

Joined: Nov 14, 2005
Posts: 324
Hi,

Is there some latest version of Websphere that support JDK 1.5


"Know where to find the solution and how to use it - that's the secret of success."
Scott Selikoff
author
Saloon Keeper

Joined: Oct 23, 2005
Posts: 3716
    
    5

WSAD was renamed to RAD. So you'd want a RAD6 something, but currently none support 1.5.


My Blog: Down Home Country Coding with Scott Selikoff
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: WSAD 5.1.2 and J2SE 1.5 Compiler