This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Websphere and the fly likes Web service with SSL Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Web service with SSL" Watch "Web service with SSL" New topic
Author

Web service with SSL

wanderer wanderer
Greenhorn

Joined: Jul 21, 2005
Posts: 2
Hi all,

I have a Axis web service deployed on WebSphere 5 and now I want to connect to that web service though SSL. I read the documentation from IBM but could not figure out the way to enable SSL for my web service. Should I enable SSL for both IBM HTTP Server and WebSphere Aplication Server? WebSphere should have a default SSL configuration right? Anyone in this forum could help me please.

Thanks
emm raha
Ranch Hand

Joined: Mar 18, 2003
Posts: 57
To enable HTTPS for a port in WAS, use the admin console to navigate to:

Servers --> Application Servers --> [yourserver] --> Web Container --> HTTP transports --> SSL enabled = true

To enable HTTPS for IBM HTTP Server, you'll need to specify your SSL certificate. They have a tool for creating default certificates, try googling for more information on that. However, your client may complain that the certificate is "from an unknown authority".
wanderer wanderer
Greenhorn

Joined: Jul 21, 2005
Posts: 2
Thanks for your answer.

I looked at the WS Administrator Console and found that there are two ports defined for my application server already -- 9085 for HTTP and 9444 for HTTPS. You are right. I saw the "Enable SSL" check box is selected in the second port.

After configuring a keystore file for IBM HTTP Server and enabling SSL for the first port, I could connect to <a href="https://<my_server_name rel="nofollow">:9085/<my_web_service_url>" target="_blank">https://<my_server_name>:9085/<my_web_service_url>

However, my problem is that I cannot connect to <a href="https://<my_server_name rel="nofollow">:9444/<my_web_service_url>." target="_blank">https://<my_server_name>:9444/<my_web_service_url>. WS logs an error message saying "Servlet Request Processor Exception: Virtual Host/WebGroup Not Found : The host <my_server_name> on port 9444 has not been defined"

Could you pls tell me why the default SSL port does not work?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Web service with SSL
 
Similar Threads
WAS 3.5.4 Security
Enabling both HTTP and HTTPS for an Web Service, deployed in the Same WAR
use of WebServers infront of enterprise app server
2 technical questions for the techies
Web service with SSL