aspose file tools*
The moose likes Websphere and the fly likes Problem with Websphere Form Based Authentication Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Problem with Websphere Form Based Authentication" Watch "Problem with Websphere Form Based Authentication" New topic
Author

Problem with Websphere Form Based Authentication

bearT
Greenhorn

Joined: Sep 02, 2005
Posts: 3
Hi,

I'm using form-based authentication for my system login and I'm facing a problem with the redirection after verifying the user credentials.

"http://mytest" displays my application login page. After I have login, the system verifies that I am a valid user and redirects me to "http://mytest/main.jsp". However, when I logout and login again using a new browser window, the system will display a blank page after I have submitted my login. The URL of the page shows "http://mytest/j_security_check".

I have found a way to get around this by deleting "j_security_check" from the URL to display the login page again. Upon submitting my login, the system will redirect me to the correct page.

May I know where does the problem lies and how I can resolve this? I have seeked many forum but I could not get much help, hence I really appreciate any comments/advice. Thanks.
David O'Meara
Rancher

Joined: Mar 06, 2001
Posts: 13459

What version of WAS are you running? We had similar behaviour in WAS 4.0.1 and 4.0.2, then it worked in 4.0.3 but was broken again in 4.0.5
Or maybe you're onanother version completely.
bearT
Greenhorn

Joined: Sep 02, 2005
Posts: 3
Hi David,

I'm using WAS 4.0.7.

Does this problem occurs with this version too? Is there any websites that I can obtain more info on this?
David O'Meara
Rancher

Joined: Mar 06, 2001
Posts: 13459

I only used the versions mentioned, I didn't get to try the version you referred to and haven't touched WAS in 2 years.

The only way we got it working was to try a version and see how far we got. Raising issues with IBM didn't help since in many cases they didn't admin it was a problem. In one situation they said it was designed to work that way. Essentially we tried each version until we found one that worked and stuck with it. When we looked at upgrading we found things stopped working again so we didn't upgrade. It made us sad.
bearT
Greenhorn

Joined: Sep 02, 2005
Posts: 3
Hi David,

Thanks for your comments
 
wood burning stoves
 
subject: Problem with Websphere Form Based Authentication