aspose file tools*
The moose likes Websphere and the fly likes com/ibm/CORBA/iiop/ORB - Help Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "com/ibm/CORBA/iiop/ORB - Help" Watch "com/ibm/CORBA/iiop/ORB - Help" New topic
Author

com/ibm/CORBA/iiop/ORB - Help

Adriana Ishikawa
Greenhorn

Joined: Oct 06, 2005
Posts: 3
Hi, help me...

I have a client application that calls a EJB in a WebSphere Server...
A part of my client is:
.
.
.
Hashtable env = new Hashtable();
env.put(Context.INITIAL_CONTEXT_FACTORY, "com.ibm.websphere.naming.WsnInitialContextFactory");
env.put(Context.PROVIDER_URL,"iiop://10.11.87.51:2809/SGBD");
Context initial = new InitialContext(env);
Object objref = initial.lookup("java:comp/env/ejb/EncerramentoJNDI");
.
.
.

When I run this.. I got this error:

java.lang.NoClassDefFoundError: com/ibm/CORBA/iiop/ORB
at com.ibm.websphere.naming.WsnInitialContextFactory.getInitialContext(WsnInitialContextFactory.java:72)
at javax.naming.spi.NamingManager.getInitialContext(Unknown Source)
at javax.naming.InitialContext.getDefaultInitCtx(Unknown Source)
at javax.naming.InitialContext.init(Unknown Source)
at javax.naming.InitialContext.<init>(Unknown Source)

Does anybody know what I need to do?

Tks...
Nathan Pruett
Bartender

Joined: Oct 18, 2000
Posts: 4121

It looks like the client can't find a JAR it needs (looks like something CORBA related...).

Moving this to the IBM WebSphere forum, where people may know more about the exact JARs you might need to supply to the client (or if something else is the problem...).


-Nate
Write once, run anywhere, because there's nowhere to hide! - /. A.C.
sridhar
Greenhorn

Joined: Sep 13, 2005
Posts: 15
see that you have server.jar and ibmorb.jar in your classpath.
Pon Sundar
Greenhorn

Joined: Oct 13, 2005
Posts: 1
I have a error

java.lang.NoClassDefFoundError: com/ibm/CORBA/iiop/GlobalORBExists

In which jar file this class available. Can you help me.
sridhar
Greenhorn

Joined: Sep 13, 2005
Posts: 15
Unfortunately didn't find com/ibm/CORBA/iiop/GlobalORBExists in any of the jar. Plz make sure whether that exists at all? Can I know where are you using that and which Env?
Cristian Negresco
Ranch Hand

Joined: Sep 15, 2001
Posts: 182
Hi,

If you are running the client side on Sun JRE and call EJB running on IBM JRE (Websphere) you might need an Application Client from IBM between Sun's JRE and your application client code.
to use with Sun's jre: http://www-128.ibm.com/developerworks/websphere/library/techarticles/0409_bhogal/0409_bhogal.html
comes with own jre:
http://publib-b.boulder.ibm.com/Redbooks.nsf/RedbookAbstracts/tips0221.html?Open
and here is general information on application clients:
http://publib.boulder.ibm.com/infocenter/wasinfo/v5r0/index.jsp?topic=/com.ibm.websphere.base.doc/info/aes/ae/ccli_pluggableclient.html

I have worked with pluggable application client only, haven't seen the exception. I guess that you only need some jars in the classpath. What are the jars depend on how do you run the code, on IBM's jre or Sun's.
Hope it helps,
Cristian
Cristian Negresco
Ranch Hand

Joined: Sep 15, 2001
Posts: 182
Hi,
Found iwsorb.jar with GlobalOrbExistsException.class. Not the same, but close..

Cristian
Stephensh Zhang
Greenhorn

Joined: May 18, 2010
Posts: 5
No J2EE environment; skipping timer manager initialization
Exception in thread "main" java.lang.NoClassDefFoundError: com/ibm/CORBA/iiop/ORB
at com.ibm.ws.naming.util.WsnInitCtxFactory.getInitialContextInternal(WsnInitCtxFactory.java:421)
at com.ibm.ws.naming.util.WsnInitCtx.getContext(WsnInitCtx.java:123)
at com.ibm.ws.naming.util.WsnInitCtx.getContextIfNull(WsnInitCtx.java:798)
at com.ibm.ws.naming.util.WsnInitCtx.lookup(WsnInitCtx.java:164)
at com.ibm.ws.naming.util.WsnInitCtx.lookup(WsnInitCtx.java:179)
at javax.naming.InitialContext.lookup(Unknown Source)
at com.ibm.cloud.bss.email.impl.EmailServiceImpl.getSession(EmailServiceImpl.java:55)
at com.ibm.cloud.bss.email.CCAbstractEmailService.createEmailSession(CCAbstractEmailService.java:40)
at com.ibm.wdp.ccp.email.AbstractEmailService.sendEmail(AbstractEmailService.java:72)
at com.ibm.cloud.bss.junit.test.TestMain.<init>(TestMain.java:29)
at com.ibm.cloud.bss.junit.test.TestMain.main(TestMain.java:39)
Caused by: java.lang.ClassNotFoundException: com.ibm.CORBA.iiop.ORB
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 11 more


Before the dream lifts you into the clouds,make sure look hard at the facts on the ground.
http://www.cnblogs.com/bruceleey
Iurii Volchyn
Greenhorn

Joined: Aug 17, 2010
Posts: 1
They way to resolve this problem found by me:
- You'll need IBM JRE. It can be downloaded as the part of IBM Development Package for Eclipse
- You will need the following JARs from <WebSphere Installation Directory>/lib
-- j2ee.jar
-- bootstrap.jar
- You will need the following JARs from <WebSphere Installation Directory>/plugins
-- com.ibm.ws.runtime.jar
-- com.ibm.ws.emf.jar
-- org.eclipse.emf.ecore.jar
-- org.eclipse.emf.common.jar
-- com.ibm.ffdc.jar
- Use "com.ibm.websphere.naming.WsnInitialContextFactory" as initial context factory

Good luck!

Regards,
Iurii Volchyn


Regards,
Iurii Volchyn
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: com/ibm/CORBA/iiop/ORB - Help