aspose file tools*
The moose likes Websphere and the fly likes EJB Deployment fails in RAD6.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "EJB Deployment fails in RAD6.0" Watch "EJB Deployment fails in RAD6.0" New topic
Author

EJB Deployment fails in RAD6.0

Debu Ganguly
Greenhorn

Joined: Dec 11, 2003
Posts: 3
I have just installed RAD6.0 . But I installed the WSAD5.1 test environment as we use WAS5.1 in Production .
However our existing EJB project which is in production will not deploy .
This project was working fine in WSAD5.1 . I have set up everything the same way . The project compiles fine and there are no validation errors .
But when I try to deploy it comes back with an error saying deployment fails .
This is what the error says :
Deployment from com.ibm.etools.ejbdeploy.EJBDeployer had errors: RMIC Command returns RC = 1. The problems which stopped RMIC are displayed, and have also been recorded in the .log file

com.ibm.etools.rmic.RMICException: RMIC Command returns RC = 1. The problems which stopped RMIC are displayed, and have also been recorded in the .log file in C:\Documents and Settings\gangudk.CORP\IBM\rationalsdp6.0\workspace\.metadata
at com.ibm.etools.rmic.RMICClassLoader.runCompile(RMICClassLoader.java:381)
at com.ibm.etools.rmic.RMICOperation.invokeRMICInJVM(RMICOperation.java:682)
at com.ibm.etools.rmic.RMICOperation.rmic(RMICOperation.java:774)
at com.ibm.etools.rmic.RMICOperation.generateStubs(RMICOperation.java:279)
at com.ibm.etools.rmic.UIRMICBeansOperation.generateStubs(UIRMICBeansOperation.java:101)
at com.ibm.etools.rmic.RMICOperation.run(RMICOperation.java:848)
at com.ibm.etools.ejbdeploy.EJBDeployer.visit(EJBDeployer.java:126)
at com.ibm.etools.ejbdeploy.EJBDeployer.doExecute(EJBDeployer.java:249)
at com.ibm.etools.ejbdeploy.EJBDeployer.execute(EJBDeployer.java:229)
at com.ibm.wtp.j2ee.deploy.J2EEDeployOperation.deploy(J2EEDeployOperation.java:90)
at com.ibm.wtp.j2ee.deploy.J2EEDeployOperation.execute(J2EEDeployOperation.java:67)
at com.ibm.wtp.common.operation.WTPOperation.doRun(WTPOperation.java:234)
at com.ibm.wtp.common.operation.WTPOperation$1.run(WTPOperation.java:168)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1673)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1693)
at com.ibm.wtp.common.operation.WTPOperation.run(WTPOperation.java:186)
at com.ibm.wtp.common.operation.WTPOperationJobAdapter.run(WTPOperationJobAdapter.java:34)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:66)


Can someone help me out ?
I was hoping for an easy migration of the IDE that I use to write code but I guess that is never the case when we work with IBM Websphere .

Thanks again .
Scott Selikoff
Saloon Keeper

Joined: Oct 23, 2005
Posts: 3704
    
    5

Originally posted by Debu Ganguly:
I was hoping for an easy migration of the IDE that I use to write code but I guess that is never the case when we work with IBM Websphere .


Far from it, migrating from WSAD5.x to RAD6.x irregardless of WebSphere is a huge step, as RAD6.x is far more buggy.

As to your specific problem, try manually deleting all the RMIC generated code in your bean projects and interfaces and regenerate it using publish.


My Blog: Down Home Country Coding with Scott Selikoff
Debu Ganguly
Greenhorn

Joined: Dec 11, 2003
Posts: 3
Hi Scott ,

I cleaned out all the rmic generated code .
But it doesnot give me the option to publish to the server .It was giing me that before I cleaned out the stubs but still the EJB wont deploy .
When I try to deploy I still get the same error .
If I start the server the server tells me the application was launched .

But it writes out a system out saying it could not find the tie class for the Bean Home which it will not as I deleted it .

Maan!! ami I having fun or not . To make matters worse I have a crazy deadline to meet on Dec 15 th and my boss wanted me to upgrade to RAD6.0 now .

Thanks for your help though cause I am lost and frustrated with IBM products its just not RAD even the IBM Portal is another junk .

Is there anything else that I can do to resolve this issue ?

Thanks .
Scott Selikoff
Saloon Keeper

Joined: Oct 23, 2005
Posts: 3704
    
    5

Here's what I suggest (I do this often when I am stuck), using RAD and export the project as an EAR then manually use the admin console to install the EAR.

Sometimes, the problem is with the data itself and it gets masked as a general error such as RMIC failure. Installation on the server is more likely to tell you what the root cause of the problem is.
Ravinder
Greenhorn

Joined: Oct 30, 2007
Posts: 1
Hi I am working on the same thing migrating an application from WSAD 5.01 to RAD 6.0. I have opened up the workspace in RAD and imported the project and cleaned up all the errors. Now when I am trying to start my local server to deploy and run the application its giving me the following exception

"Call stack:
com.ibm.ws.ejbpersistence.utilpm.PersistenceManagerException: PMGR1010E: The current backend id,DB2UDBNT_V72_1, does not have equivalent deployed code in the jar."

Can any of you please advise me where the problem is. I have even setup all the datasource and everything fine. Appreciate your advise.


junky
durga ramakrishnan
Greenhorn

Joined: Jul 30, 2007
Posts: 14
Hi Ravider,
Iam working with websphere 6...My project contains html,javascripts,servlets and ejb.iam using oracle 8i.i have been trying to create datasource for my project using jdbc provider but iam getting error and exception as follows when clicking "Test connection"

"Test connection failed for data source Oracle JDBC Driver DataSource on server server1 at node durgaNode02 with the following exception: java.lang.IllegalArgumentException: resolve against non-hierarchical or relative base. View JVM logs for further details."

can you please help me regarding this...Thanks in advance

Thanks,
durga
Raghavan Muthu
Ranch Hand

Joined: Apr 20, 2006
Posts: 3344

Hi,

I have got involved into this WSAD-RAD Migration sometimes back. But what i had to take care of manual steps is towards teh Struts (Web) Projects and NOT with EJB projects eventhough we had both.

I don't have the pdf with me right now. But you can just search in google or more precisely in IBM site itself for "WSAD to RAD Migration". There is a pdf which neatly explains the whole stuff. If you patiently look into it and follow the guidelines you may get the issues resolved.

Good luck!


Everything has got its own deadline including one's EGO!
[CodeBarn] [Java Concepts-easily] [Corey's articles] [SCJP-SUN] [Servlet Examples] [Java Beginners FAQ] [Sun-Java Tutorials] [Java Coding Guidelines]
Scott Selikoff
Saloon Keeper

Joined: Oct 23, 2005
Posts: 3704
    
    5

"Ravinder"

Your name still does not conform to the JavaRanch Naming Policy. Please review the policy and update it appropriately. This is your second warning.

Scott
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: EJB Deployment fails in RAD6.0