File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Websphere and the fly likes JNDI Resource Bindings Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "JNDI Resource Bindings" Watch "JNDI Resource Bindings" New topic

JNDI Resource Bindings

Ananth Prakash

Joined: Apr 03, 2006
Posts: 8
I am using WSAD 5.1.0 to develop my appln. When i tried to explore the JNDI through the servlet which connects to a DB2 database and displays records from a table, I'm getting the expected result. But in the server's console window, I am seeing the following error message:

"Resource reference jdbc/Db2TDataSource could not be located, so default values of the following are used: [Resource-ref settings]
Resource reference jdbc/sbtdatasource could not be located, so default values of the
following are used: [Resource-ref settings]

res-auth: 1 (APPLICATION)
res-isolation-level: 0 (TRANSACTION_NONE)
res-sharing-scope: true (SHAREABLE)
res-resolution-control: 999 (undefined),"

In my web.xml file, I have given a reference name to the JNDI name 'jdbc/DB2TDataSource' and I'm using the reference name in the Initial context lookup. The code snippet goes like this.

InitialContext ctx = null;
ctx = new InitialContext();
ds = (DataSource) ctx.lookup("java:comp/env/jdbc/DB2TDataSource");

I had read in the earlier postings that I need to use a Resource reference value in the Initial Context lookup for this error to stop. But I still get the above error in my console window.

Need help in this regard.

Alana Sparx
Ranch Hand

Joined: Feb 14, 2006
Posts: 121
I've defined a datasource, giving a jndi binding of 'jdbc/ds1'.

This is the name I use when attempting to connect to the datasource

In your case try altering the following line from


Good luck.
Babji Reddy
Ranch Hand

Joined: Jan 24, 2006
Posts: 106
Usage of JNDI names is deprecated in Webshpere. You have to use reference bindings.
Define the resource references to the Database JNDI in web/ejb deployment descriptors, and use context.lookup("java:comp/env/<YOUR REF JNDI>").

This will suppress the warning (its not an error) in the console
I agree. Here's the link:
subject: JNDI Resource Bindings
It's not a secret anymore!