It's not a secret anymore!
The moose likes Websphere and the fly likes Getting error while deploying Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Getting error while deploying" Watch "Getting error while deploying" New topic

Getting error while deploying

Deepa More
Ranch Hand

Joined: May 22, 2006
Posts: 68
Getting following error on deploying war file on admin console.

The EAR file could be corrupt and/or incomplete.

Jeanne Boyarsky
author & internet detective

Joined: May 26, 2003
Posts: 32819

You can deploy a WAR file on the admin console? How do you specify it is a WAR instead of an EAR? It looks like WebSphere thinks you are deploying an EAR.

In the future, please specify what version of WebSphere you are using.

[OCA 8 book] [Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Other Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, TOGAF part 1 and part 2
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper

Joined: Aug 26, 2006
Posts: 4968

Are you deploying through the admin console, or through a JACL script?

If you're having a problem with a script, I've got a few examples on my website if you'd like to see them:


Deepa More
Ranch Hand

Joined: May 22, 2006
Posts: 68
I am using IBM WEBSPHERE APPLICATION SERVER, v. 5.1, and On admin console, Using the option Install New Application, I am specifying my war file name in local path and when I click Next it gives me above error.
What is wrong with this I am not able to understand?
Do anyone has idea about this?
Thanks for the reply.
Deepa More
Ranch Hand

Joined: May 22, 2006
Posts: 68
I found the place why it has occured. Actually 2 of the jars required for project were corrupted. Hence war file was not getting deployed.
BTW Thanks for your precious reply.
I agree. Here's the link:
subject: Getting error while deploying
It's not a secret anymore!