aspose file tools*
The moose likes Websphere and the fly likes Application hangs with prior J2CA0086W warning messages Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Application hangs with prior J2CA0086W warning messages" Watch "Application hangs with prior J2CA0086W warning messages" New topic
Author

Application hangs with prior J2CA0086W warning messages

Anand Gondhiya
Ranch Hand

Joined: Feb 24, 2004
Posts: 155
my application hangs while executing a Stored proc or select/insert/update SQL statements. I am using WebSphere App server 5.1 and WSAD

Case 1 ata Source/Connection pool
I had set up sharable Data source.and It always worked fine.I am making sure that I am closing connections after using them. Suddenly , application started hanging. I increased max connections from 10 to 100 but no diffrence.Application hangs with prior J2CA0086W warning messages.
for more info: http://www-1.ibm.com/support/docview.wss?uid=swg21121449
There is no diffrence in behaviour if I restart WebSphere App server or restart WSAD. However ,after rebooting application works fine for first time. and then onwards , It hangs.

Case 2: DriverManager
Before I set up connection pool/Data Source ,Application worked fine with Driver manager. But after switching back from DataSource/Conn Pool , my application hangs even if I use DriverManager.

Can anyone advise ?
Thanks
-Anand
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper

Joined: Aug 26, 2006
Posts: 4968
    
    1

Are there any firewalls between the app server and the database?

Can you post your datasource settings? Are there anything peculiar there?


-Cameron McKenzie
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Application hangs with prior J2CA0086W warning messages