aspose file tools*
The moose likes Websphere and the fly likes Error while publishing Test Environment  Server V6  in RAD 6 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Error while publishing Test Environment  Server V6  in RAD 6" Watch "Error while publishing Test Environment  Server V6  in RAD 6" New topic
Author

Error while publishing Test Environment Server V6 in RAD 6

Priyadarshan Kelkar
Ranch Hand

Joined: Apr 04, 2007
Posts: 31
hi ,

I added my EAR file to the Integrated Websphere Test Environment V6 in RAD. But while publishing the server it gives me following error:

Publish completed with errors and/or warnings. Please see server logs for more details.
Publishing MyEar_Ear to WebSphere v6.0 Server @ localhost
Reinstalling Application.
Installation Completed Sucessfully:
Starting Application: MyEar_Ear
Application Failed to Start. MyEar_Ear
null nested exception is com.ibm.ws.exception.RuntimeWarning: com.ibm.ws.webcontainer.exception.WebAppNotLoadedException: Failed to load webapp: Failed to load webapp: Context root /* is already bound.
Cannot start application MyEar WEB PROJECT
Please see server logs for more details.

Please can anyone let me know where are server logs ? Also just as we have Environment, Security, Data Source tabs in Test Environment v5.0/v5.1, I am not able to see any such tabs for Test Environment v6.0. How do I get to the Administrative console ?

Thanks for your support.
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper

Joined: Aug 26, 2006
Posts: 4968
    
    1

The application.xml file of the ear will specify the context root for the web application. Is there any chance you can show us the application.xml file of your app, without violating any confidentiality?

Perhaps giving the war file a different context root name will solve your problem.

-Cameron McKenzie
Priyadarshan Kelkar
Ranch Hand

Joined: Apr 04, 2007
Posts: 31
i want to reply with an xml file. but the post is not getting printed properly due to xml tags ... can anyone help me with proper posting first ?
Priyadarshan Kelkar
Ranch Hand

Joined: Apr 04, 2007
Posts: 31
hi Cameron,

[application id="Application_ID"]
[display-name]MyEar_Ear[/display-name]
[module id="WebModule_1101811035663"]
[web]
[web-uri]MyWar_WAR-1.0.war[/web-uri]
[context-root]/[/context-root]
[/web]
[/module]
[/application]

This is my application.xml. Please ignore the '[',']' braces and treat them as '<', '>' respectively. Please suggest a solution.
[ April 09, 2007: Message edited by: Priyadarshan Kelkar ]
Ratan Kumar
Ranch Hand

Joined: Jul 19, 2006
Posts: 67
Hi,

Even i want to use RAD6 Test Environment. But i guess it does not have the same look and feel for the server related tabs you are lookng out for like Environment, Security, Data Source tabs in Test Environment v5.0/v5.1.

You can do all the datasource configuration through the EAR module.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: Error while publishing Test Environment Server V6 in RAD 6