• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Error while publishing Test Environment Server V6 in RAD 6

 
Priyadarshan Kelkar
Ranch Hand
Posts: 31
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi ,

I added my EAR file to the Integrated Websphere Test Environment V6 in RAD. But while publishing the server it gives me following error:

Publish completed with errors and/or warnings. Please see server logs for more details.
Publishing MyEar_Ear to WebSphere v6.0 Server @ localhost
Reinstalling Application.
Installation Completed Sucessfully:
Starting Application: MyEar_Ear
Application Failed to Start. MyEar_Ear
null nested exception is com.ibm.ws.exception.RuntimeWarning: com.ibm.ws.webcontainer.exception.WebAppNotLoadedException: Failed to load webapp: Failed to load webapp: Context root /* is already bound.
Cannot start application MyEar WEB PROJECT
Please see server logs for more details.

Please can anyone let me know where are server logs ? Also just as we have Environment, Security, Data Source tabs in Test Environment v5.0/v5.1, I am not able to see any such tabs for Test Environment v6.0. How do I get to the Administrative console ?

Thanks for your support.
 
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper
Posts: 4968
1
Hibernate Spring Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The application.xml file of the ear will specify the context root for the web application. Is there any chance you can show us the application.xml file of your app, without violating any confidentiality?

Perhaps giving the war file a different context root name will solve your problem.

-Cameron McKenzie
 
Priyadarshan Kelkar
Ranch Hand
Posts: 31
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i want to reply with an xml file. but the post is not getting printed properly due to xml tags ... can anyone help me with proper posting first ?
 
Priyadarshan Kelkar
Ranch Hand
Posts: 31
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi Cameron,

[application id="Application_ID"]
[display-name]MyEar_Ear[/display-name]
[module id="WebModule_1101811035663"]
[web]
[web-uri]MyWar_WAR-1.0.war[/web-uri]
[context-root]/[/context-root]
[/web]
[/module]
[/application]

This is my application.xml. Please ignore the '[',']' braces and treat them as '<', '>' respectively. Please suggest a solution.
[ April 09, 2007: Message edited by: Priyadarshan Kelkar ]
 
Ratan Kumar
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Even i want to use RAD6 Test Environment. But i guess it does not have the same look and feel for the server related tabs you are lookng out for like Environment, Security, Data Source tabs in Test Environment v5.0/v5.1.

You can do all the datasource configuration through the EAR module.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic