wood burning stoves 2.0*
The moose likes Websphere and the fly likes Teradata Datasource configuration on WAS V5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Teradata Datasource configuration on WAS V5" Watch "Teradata Datasource configuration on WAS V5" New topic
Author

Teradata Datasource configuration on WAS V5

Karthick Sundaram
Greenhorn

Joined: Feb 04, 2007
Posts: 9
Hi All,

I'm facing a peculiar problem when using Teradata Datasources with Websphere .well..the version is 5.X.. (has jdk 1.4)

I'm using Teradata JDBC Driver. I've configured it on the console. And When I test the Datasource, it says connection successful.

When I use the application, I'm getting an exception. I'm putting forward what all I have done in configuring the Datasource and JDBC provider.

I made an entry for the teradata driver in the Websphere env variables: /apps/dw/saart/htdocs/SAARTONLINEWebEAR.ear/SAARTONLINEWeb.war/WEB-INF/lib/

I've added a JDBC Provider specifying the jar file containing the driver and the TeraconnectionpooDataSource class which is the implementation class.

under Datasource I created a Datasource TeradataDatasource and provided a jndi name. and added a few custom properties like user,password,DATABASE,DSName.

I added J2C authentication entries also with the username and the password and mapped it against (component managed alias) when I installed the application.

When I'm testing the connection for the Datasource, it says connection is successful, but when I'm trying to access from the application(servlet), it throws an exception.

Context ctx = new InitialContext();
dataSource =(DataSource)ctx.lookup("jdbc/teradata");
connection = dataSource.getconnection() //earlier I tried with getConnection("uatb01","uatb01"); Doesn't work
stmt = connection.createStatement();
rset = stmt.executeQuery(query.toString());

The exception thrown is


Method createManagedConnctionWithMCWrapper caught an exception during creation of the ManagedConnection for resource jdbc/teradata, throwing ResourceAllocationException. Original exception: com.ibm.ws.exception.WsException: DSRA0080E: An exception was received by the Data Store Adapter. See original exception message: [NCR] [Teradata DBMS] : Invalid password.. with SQL State : 28000 SQL Code : 3003

All the passwords are working fine. I tried logging on to the Teradata machine. I'm able to execute queries.

I've attached a compressed archive. It contains the screenshots of the Websphere admin console. and also the jar files which contain the Teradata driver files. all the jar files are in the class path.

The same configurations are working for WAS 6. I'm trying to find out why this is not working for WAS5.

I really appreciate all your suggestions and help.

Thanks.
Karthick


SCJP 1.4, SCWCD for J2EE 1.4
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: Teradata Datasource configuration on WAS V5
 
Similar Threads
How to configure Tera data data source in WAS6.1
Tutorial PostgreSQL 8.3 on Glassfish V2.1 for ConnectionPool in Netbeans 6.5.1, WindowsXP (Post 3)
java.sql.SQLException: No suitable driver
Oracle or DB2 configuration with Websphere
Setting up Teradata DataSource in WSAD 5.1.2