*
The moose likes Websphere and the fly likes Problem with Compile java classes Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Problem with Compile java classes" Watch "Problem with Compile java classes" New topic
Author

Problem with Compile java classes

Anand Gondhiya
Ranch Hand

Joined: Feb 24, 2004
Posts: 155
Hello,

I use Java 1.3 , WebSphere App server, WSAD 5.1. My WSAD workspace has been setup fine from last 1 year. Just now I saw that When I build the project , the all the classes are NOT being created in WEB-INF\classes directory.

I am very surprised as it generates only 3 .class files instead of generating 15 of them.

Any ideas ?
Ed Thompson
Ranch Hand

Joined: Jan 20, 2006
Posts: 43
Anything showing up in the Problems window?


Even if the voices <i>aren't</i> real, they still have some good ideas!
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper

Joined: Aug 26, 2006
Posts: 4968
    
    1

Does the same hold true when you export the war?

Export the war file and open it up in WinZip. I bet you the class files will be inside.

-Cameron McKenzie
Venkatesh Sandrasegaran
Greenhorn

Joined: Jun 13, 2007
Posts: 8
i have exactly same problem. had you got this fixed ? any suggestion would be of greater help.

Thanks in advance,
Venkatesh S
Muthu Marthandam
Greenhorn

Joined: Nov 01, 2007
Posts: 2
Originally posted by Venkatesh Sandrasegaran:
i have exactly same problem. had you got this fixed ? any suggestion would be of greater help.

Thanks in advance,
Venkatesh S



While export as WAR file , check for option like don't export with warning / compile error , if so uncheck that option
Anand Gondhiya
Ranch Hand

Joined: Feb 24, 2004
Posts: 155
Looks like there was one jar file changed in the project. This jar file came from Business Object and was built using JDK 1.4. My project was built using JDK 1.3

As JDK version was diffrent in this jar file and my project , it gave errors and generated only 3 class files for some reason.

for those with this problem, you can force WSAD 5.1 to use JDK 1.4 version. by setting up JDK 1.4 jars in library.

Thanks everyone for helping me out.
-Anand.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Problem with Compile java classes
 
Similar Threads
String.split() - new in 1.4.2?
wsad
WSADIE 5 - How do I Set High Values?
Jar File Dependencies - Class not Found Exception
urgent pls! WSAD JVMPI settings