aspose file tools*
The moose likes Websphere and the fly likes WAS toolkit eclipse startup errors after update to fixpack 17  Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "WAS toolkit eclipse startup errors after update to fixpack 17  " Watch "WAS toolkit eclipse startup errors after update to fixpack 17  " New topic
Author

WAS toolkit eclipse startup errors after update to fixpack 17

Stuart Swearengen
Greenhorn

Joined: Nov 02, 2006
Posts: 26
WAS 6.1 toolkit worked fine up until I updated it to fixpack 17 on xp using the rational updater. I now get the following errors on startup.

I assume it is the cunning issue of jars not being available. Any thoughts on how to fix it?

Thanks

*************************************************************

!SESSION 2008-07-15 14:28:32.261
eclipse.buildId=o0620.07
java.fullversion=J2RE 1.5.0 IBM J9 2.3 Windows XP x86-32 j9vmwi3223-20071007 (JIT enabled)
J9VM - 20071004_14218_lHdSMR
JIT - 20070820_1846ifx1_r8
GC - 200708_10
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.core.runtime 4 0 2008-07-15 14:28:33.277
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)"
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java :294)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.j ava:329)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java: 1046)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartL evelManager.java:573)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelMa nager.java:495)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(Star tLevelManager.java:275)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartL evelManager.java:455)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.jav a:189)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.j ava:291)

!ENTRY org.eclipse.update.configurator 4 0 2008-07-15 14:28:33.277
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)"
at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java :294)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.j ava:329)
at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java: 1046)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartL evelManager.java:573)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelMa nager.java:495)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(Star tLevelManager.java:275)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartL evelManager.java:455)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.jav a:189)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.j ava:291)

!ENTRY org.eclipse.osgi 4 0 2008-07-15 14:28:33.293
!MESSAGE Bundle initial@reference:file lugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2008-07-15 14:28:33.293
!MESSAGE Bundle initial@reference:file lugins/org.eclipse.update.configurator_3.2.2.R32x_v2007 07131658.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2008-07-15 14:28:33.308
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLa uncher.java:65)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.ja va:43)
at java.lang.reflect.Method.invoke(Method.java:618)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
at org.eclipse.core.launcher.Main.run(Main.java:973)
at org.eclipse.core.launcher.Main.main(Main.java:948)

!ENTRY org.eclipse.osgi 2 0 2008-07-15 14:28:33.371
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-07-15 14:28:33.371
!MESSAGE Bundle initial@reference:file lugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-07-15 14:28:33.371
!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-07-15 14:28:33.371
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-07-15 14:28:33.371
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-07-15 14:28:33.371
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-07-15 14:28:33.371
!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-07-15 14:28:33.371
!MESSAGE Bundle initial@reference:file lugins/org.eclipse.update.configurator_3.2.2.R32x_v2007 07131658.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2008-07-15 14:28:33.371
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).

!ENTRY org.eclipse.osgi 2 0 2008-07-15 14:28:33.386
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-07-15 14:28:33.386
!MESSAGE Bundle initial@reference:file lugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ [1] was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-07-15 14:28:33.386
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-07-15 14:28:33.386
!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-07-15 14:28:33.386
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-07-15 14:28:33.386
!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-07-15 14:28:33.386
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-07-15 14:28:33.386
!MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-07-15 14:28:33.386
!MESSAGE Bundle initial@reference:file lugins/org.eclipse.update.configurator_3.2.2.R32x_v2007 07131658.jar/ [2] was not resolved.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2008-07-15 14:28:33.386
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
Matthieu Scholler
Greenhorn

Joined: Feb 02, 2010
Posts: 1
Hi all,

I got the same problem (and below URL was not really high in Google answers) and below is IBM's answer:
http://www-01.ibm.com/support/docview.wss?uid=swg21285471

Basically the answer is uninstall everything, install the new version.

Cheers,
Matthieu
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: WAS toolkit eclipse startup errors after update to fixpack 17