• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem in specifying native libraries in WAS 6.1

 
kranthi aella
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,
I am migrating an application running on sub one web server 6.0 to WAS 6.1 and running into a problem while configuring native libraries.
My application code depends on a jar(abc.jar) file which in turn requires DLL(Mobius) files to connect to a reporting tool.

In web sphere i have a made a shared library and have set the classpath to abc.jar and the native library path to C:/Mobius.

In the class loader for the server i have refereced this shared library.

While running the appliation i get the following error message

java.lang.UnsatisfiedLinkError: C:\Mobius\ReginiJni.dll (JVMPORT015E Unable to resolve DLL references - a prerequisite DLL may be missing) at java.lang.ClassLoader.loadLibraryWithPath(ClassLoader.java:953) at java.lang.ClassLoader.loadLibraryWithClassLoader(ClassLoader.java:918) at java.lang.System.loadLibrary(System.java:451) at com.mobius.regini.ReginiApi.(ReginiApi.java:84) at java.lang.J9VMInternals.initializeImpl(Native Method) at java.lang.J9VMInternals.initialize(J9VMInternals.java:177) at com.mobius.vdrapi.DocumentServerFactory.(DocumentServerFactory.java:307) at pony.RptServer.GetDocumentServer(RptServer.java:96) at pony.RptServer.Authenticate(RptServer.java:124) at net.bams.security.AccessLoginModule.login(AccessLoginModule.java:168) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:64) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:615) at javax.security.auth.login.LoginContext.invoke(LoginContext.java:795) at javax.security.auth.login.LoginContext.access$000(LoginContext.java:209) at

I am thinking myy application is not able to find the native librarires.

Can some one help me in finding the problem in configuring the native libraries for an application on WAS 6.1.

thanks in advance
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic