File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Oracle/OAS and the fly likes how to start oracle from command line Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Oracle/OAS
Bookmark "how to start oracle from command line" Watch "how to start oracle from command line" New topic
Author

how to start oracle from command line

zb cong
Ranch Hand

Joined: Jan 14, 2002
Posts: 416
hello
i download and install oracle10g in my laptop computer(windows xp),and works well.in order to save the resource of my machine,i modify all the oracle services in the windows service console to MANUAL,when i need,i can start it from the service console.

but sometimes,i need to start the oracle from the dos windows,i execute following command sequence:

1 lsnrctl start
the tns listener can be started successfully.
2 set oracle_sid=mydb
mydb is my oracle instance name.
3 sqlplus /nolog
i can enter the sqlplus prompt.
4 connect /as sysdba
failed,"ORA-12560: TNS: protocol adapter error".
if i start my oracle instance FIRST from the windows service console,then the "connect /as sysdba" works.


but i want to start oracle COMPLETELY from the command line,how?

thank for any helps!!!
Stefan Wagner
Ranch Hand

Joined: Jun 02, 2003
Posts: 1923

Don't you have to define the SID before starting lsnctrl?


http://home.arcor.de/hirnstrom/bewerbung
Nicholas Cheung
Ranch Hand

Joined: Nov 07, 2003
Posts: 4982
Have you checked for the configuration files?

Nick


SCJP 1.2, OCP 9i DBA, SCWCD 1.3, SCJP 1.4 (SAI), SCJD 1.4, SCWCD 1.4 (Beta), ICED (IBM 287, IBM 484, IBM 486), SCMAD 1.0 (Beta), SCBCD 1.3, ICSD (IBM 288), ICDBA (IBM 700, IBM 701), SCDJWS, ICSD (IBM 348), OCP 10g DBA (Beta), SCJP 5.0 (Beta), SCJA 1.0 (Beta), MCP(70-270), SCBCD 5.0 (Beta), SCJP 6.0, SCEA for JEE5 (in progress)
Paul creamer
Greenhorn

Joined: Dec 03, 2004
Posts: 1
I had a problem and tried to totally reinstall version 9.
I got this error previous to the resinstall and now continue to get same error. Oracle said to re-install XP, which isnt gonna happen.
I hate when phone techs, say reinstall OS...when it isnt really the reason or the fault. I dont plan to reinstall this pc's os just for oracle.
When I did the reinstall it was fresh install in that I removed all site of ORACLE anything from registry and from the HD.
The windows eror at the end tells me its external to oracle and maybe something else, and maybe a windows problem but I wont reinstall XP on this computer just to fix oracle....or at least not till Im ready to.


LSNRCTL for 32-bit Windows: Version 9.0.1.1.1 - Production on 03-DEC-2004 22:32:19

Copyright (c) 1991, 2001, Oracle Corporation. All rights reserved.

Starting tnslsnr: please wait...

TNSLSNR for 32-bit Windows: Version 9.0.1.1.1 - Production
System parameter file is D:\oracle\ora90\network\admin\listener.ora
Log messages written to D:\oracle\ora90\network\log\listener.log
Error listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=pjc-office)(PORT=1521)))
TNS-12546: TNS ermission denied
TNS-12560: TNS rotocol adapter error
TNS-00516: Permission denied
32-bit Windows Error: 13: Permission denied

Listener failed to start. See the error message(s) above...

pjc@pcreamer.com
[ December 03, 2004: Message edited by: Paul creamer ]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: how to start oracle from command line
 
Similar Threads
how to start Oracle databse server
accept command in .sql file not working from ant
Unable to establish a network connection
Sys user as sysdba
ORA-1113:Can not open database