This week's book giveaway is in the OCAJP 8 forum.
We're giving away four copies of OCA Java SE 8 Programmer I Study Guide and have Edward Finegan & Robert Liguori on-line!
See this thread for details.
The moose likes Tomcat and the fly likes strange? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA Java SE 8 Programmer I Study Guide this week in the OCAJP 8 forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "strange?" Watch "strange?" New topic
Author

strange?

sonny kher
Ranch Hand

Joined: Nov 06, 2001
Posts: 83
I am a tomcat newbie so bear with me, please.
I installed it on a redhat linux system and I can run the examples but get this...only when i am runnin it in debug mode. When I run it normally, I get a segmentation fault
usr/bin/dtomcat4: line 272: 4946 Segmentation fault
$JAVA_HOME/bin/java $CATALINA_OPTS -classpath $CP
-Dcatalina.base=$CATALINA_BASE -Dcatalina.home=$CATALINA_HOME
org.apache.catalina.startup.Bootstrap "$@" start
can anybody point me in the right direction? if you need more information, please let me know
thanks


_ __________________ _ <br />RHCE<br />SCJP<br />??:-(
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 17149
    
  27

Don't know about Tomcat, but WebLogic Version 6 segfaults with the default shell settings.
Try issuing the command "ulimit -s 2048" before starting Tomcat.


An IDE is no substitute for an Intelligent Developer.
sonny kher
Ranch Hand

Joined: Nov 06, 2001
Posts: 83
thanks tim, that really helped. That and I had some missing xml libs, funny how it still worked in the debugger.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: strange?
 
It's not a secret anymore!