wood burning stoves*
The moose likes Tomcat and the fly likes Win98SE & Tomcat 4 setup problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Win98SE & Tomcat 4 setup problem" Watch "Win98SE & Tomcat 4 setup problem" New topic
Author

Win98SE & Tomcat 4 setup problem

dodo dimitrius
Greenhorn

Joined: Dec 04, 2001
Posts: 24
Hi everyone,
I have a problem, setting up Tomcat 4.0.1 in Win98SE. Autoexec.bat setting is:
PATH=C:\WINDOWS;C:\JDK1.3\BIN;C:\JDK1.3\LIB
set JAVA_HOME=C:\WINDOWS;C:\JDK1.3
set CATALINA_HOME=C:\JAKARTA-TOMCAT-4.0.1
When I double click on the startup.bat in the Tomcat bin directory, DOS window opens with the message:
Using CATALINA_BASE: C:\JAKARTA-TOMCAT-4.0.1
Using CATALINA_HOME: C:\JAKARTA-TOMCAT-4.0.1
Using CLASSPATH: C:\JAKARTA-TOMCAT-4.0.1\bin\bootstrap.jar:C:\WINDOWS;C:\JDK1.3\lib\tools.jar
Using JAVA_HOME: C:\WINDOWS;C:\JDK1.3
Bad command or file name
When I try to open Tomcat home page, 'http://localhost/8080/', I get "Page cannot be displayed." message.
Can anyone help!
Thanks
Berko

------------------
Ashik Uzzaman
Ranch Hand

Joined: Jul 05, 2001
Posts: 2370

Hi berko try to set the followings in ur autoexec.bat and also in DOS-Window, all in lower-case (better) and no extra terminator/space unless needed...
set path=c:\jdk1.3\bin;%path%
set classpath=c:\jdk1.3\lib;c:\jdk1.3\lib\tools.jar;c:\jdk1.3\lib\servlet.jar
set java_home=c:\jdk1.3
set catalina_home=c:\jakarta-tomcat-4.0.1
For a detailed explanation check out this thread.

------------------
Muhammad Ashikuzzaman (Fahim)
Sun Certified Programmer for the Java� 2 Platform
--When you learn something, learn it by heart!


Ashik Uzzaman
Senior Member of Technical Staff, Salesforce.com, San Francisco, CA, USA.
dodo dimitrius
Greenhorn

Joined: Dec 04, 2001
Posts: 24
Hello Fahim,
Thanks for your reply. I did everything as you wrote, and now I can start running Tomcat, and display index.html page. DOS window named "java" open, with the text:
Starting service Tomcat_Standalone
Apache Tomcat/4.0.1
Starting service Tomcat-Apache
Apache Tomcat/4.0.1
I copied servlet.jar from common/lib directory to the jdk1.3\lib.
Now, I have another problem. When I click on the links(located in the Web applications box), to display jsp or servlet examples, I get page with the message:
Apache Tomcat/4.0.1 - HTTP Status 404 - /jsp/
type Status
message /jsp/
description The requested resource (/jsp/) is not available.
It won't display default index.html page located in the examlpe/jsp/ subdirectory.
I tried to type full path to the index.html file, without clicking on the link, and it is still the same.
Simply, it does not run jsp nor servlets.
I hope you can help me.
Thanks
Berko
 
 
subject: Win98SE & Tomcat 4 setup problem
 
Similar Threads
Pls Help!
configuring tomcat in win98
Tomcat Installation
Tomcat 4.0.1startup problem on Windows ME
The CATALINA_HOME enviornment variable