Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem in starting tomcat

 
Rashid Ali
Ranch Hand
Posts: 349
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am facing the following error when i write: 'tomcat run' at console.

Out of environment space
Out of environment space
Out of environment space
Out of environment space
Out of environment space
Using classpath: D:\tomcat\classes;D:\tomcat\lib\webserver.jar;D:\tomcat\lib\xml.jar
Exception in Thread "main" java.lang.NoClassDefFound Error:
javax/servlet/ServletRequest
at org.apache.tomcat.startup.tomcat.execute(Tomcat.java:136)
at org.apache.tomcat.startup.tomcat.main(Tomcat.java:163)

I am running Win98 amd enen if i have set my enviornment space of DOS i am having this 'out of environment space' error. Also i have set the .bat setting of tomcat mean tomcat path and java home setting.
I think the other error is created by ServletRequest file.
Please help if you can sort out the problem.
Thanks in advance
Rashid Ali
 
rom chatterjee
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This is in the downloadable documentation on the Apache site. Briefly right click on the startup.bat and select properties. Select the memory tab and change the initial environment to something big like 4096 and click OK. Do the same for the shutdown.bat.
You will notice that there will be startup and shutdown DOS shortcuts in your directory. Use these to start/stop Tomcat.
Hope this helps
 
Rashid Ali
Ranch Hand
Posts: 349
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am sorry but after doing so as per your instruction means setting the invironment variables, i could not be able to run the tomcat.
Please sort out the problem and help.
Rashid Ali
 
Rashid Ali
Ranch Hand
Posts: 349
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks I solved the tricky problem...
Actually I was setting my environment setting from my desktop shortcut of MS-DOS. I also set the setting of .bat files in tomcat/bin directory.
But when after changing this environment setting i used to start my MS DOS from start > programs > MS-DOS menu not from the desktop shortcut.
When I did change my environment setting from Program menu then i could be able to run my tomcat.
Just for your info.
Rashid Ali
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic