aspose file tools*
The moose likes Tomcat and the fly likes Virtual Host not Functioning properly!!!!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Virtual Host not Functioning properly!!!!!" Watch "Virtual Host not Functioning properly!!!!!" New topic
Author

Virtual Host not Functioning properly!!!!!

Rishi Singh
Ranch Hand

Joined: Dec 09, 2000
Posts: 321
Iam facing a strange problem with the virtual host setting.I have kept my class files in a jar and set the classpath to this jar.We are having a team of 15 each one of them having its own virtual host, web.xml and each one is sharing a common gateway servlet.The utility classes which the gateway servlet uses in kept in /var/warehouse/common_class_links. and the class-path to these is set on each virtual host.The gateway servlet uses a Global configuration class to read the properties files which are required in the init method of the gateway servlet.The problem which persists is when one user gives a request to the server his default display page is shown , but when the second user gives a request from his virtual host it shows him the previous user default page.Iam not able to figure out whether a single instance of the gateway servlet is getting created or multiple instances are there for every virtual host.How can we set, allocate seperate jvm's for the virtual host.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Virtual Host not Functioning properly!!!!!