Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

problem on startup tomcat 4.0

 
david hu
Ranch Hand
Posts: 143
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can anyone tell me why when I use startup.bat to start the tomcat, there are following error messges?
Thanks a lot
---------------
Catalina.start: LifecycleException: null.open: java.net.BindException: Address
in use: JVM_Bind
LifecycleException: null.open: java.net.BindException: Address in use: JVM_Bin
d
at org.apache.catalina.connector.http.HttpConnector.initialize(HttpConne
ctor.java:1116)
at org.apache.catalina.core.StandardService.initialize(StandardService.j
ava:454)
at org.apache.catalina.core.StandardServer.initialize(StandardServer.jav
a:552)
at org.apache.catalina.startup.Catalina.start(Catalina.java:775)
at org.apache.catalina.startup.Catalina.execute(Catalina.java:681)
at org.apache.catalina.startup.Catalina.process(Catalina.java:179)
at java.lang.reflect.Method.invoke(Native Method)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:218)
----- Root Cause -----
java.net.BindException: Address in use: JVM_Bind
at java.net.PlainSocketImpl.socketBind(Native Method)
at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:405)
 
Mike Curwen
Ranch Hand
Posts: 3695
IntelliJ IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The answer is in the stack trace.This means that something else (probably Tomcat) is already running on a port that Tomcat is trying to obtain.

If you installed Tomcat 4.x on a Windows system, you had the option at install time to install Tomcat as a service. If you did this, then Tomcat will automatically start with your PC. Attempting to start it again will result in this error.

To remove the service, you need to use the Control Panel and set that service to "manual" as opposed to "automatic"

Also, moving this from Servlets -> Apache/Tomcat
 
Kevin Cao
Ranch Hand
Posts: 55
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I had the same problem (using eclipse), so what is the name of the services I should change in control panel.
Thanks
kevin
 
Kevin Cao
Ranch Hand
Posts: 55
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I reinstalled tomcat with a full installation, now I can see the "Apache Tomact" in service. But the prolem still there. I start Tomcat through Eclipse, it works fine whenever I was connecting with the internet. I think my problem is with my windows2000, it doesn't clear those instances of Tomact in those ports. Is there anyway to fix this? Your help is much appreciated.
Kevin Cao
 
Rahul Mahindrakar
Ranch Hand
Posts: 1868
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The solution is very simple
Go to the server.xml file in your tomcat conf directory
Modify the below line
<Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
port="8080" minProcessors="5" maxProcessors="75"
enableLookups="true" redirectPort="8443"
acceptCount="100" debug="0" connectionTimeout="20000"
useURIValidationHack="false" disableUploadTimeout="true" />
and change the port 8080 to lets say 8090
use the url http://localhost:8090 to access the web application.
This is the simplest solution
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic