jQuery in Action, 2nd edition*
The moose likes Tomcat and the fly likes Problem with Server-Side Include (SSI) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Problem with Server-Side Include (SSI)" Watch "Problem with Server-Side Include (SSI)" New topic
Author

Problem with Server-Side Include (SSI)

Nazmul Huda Sarkar
Ranch Hand

Joined: Feb 01, 2002
Posts: 317
I'm using Tomcat4.0 for my servlet engine...
But my SSI does not run....
Jasson Hunter says that "A server that supports SSI detect the <SERVLET> tag...." ..what does it mean....doesn't Tomact4.0 support SSI ? If it does whats my fault ? I'm using IE5


Nazmul<br />SCJP,SCWCD,IBM OOAD with UML
Mike Curwen
Ranch Hand

Joined: Feb 20, 2001
Posts: 3695

This is a configuration issue, so...

Moving from Servlets -> Apache/Tomcat
Thomas Paul
mister krabs
Ranch Hand

Joined: May 05, 2000
Posts: 13974
From the Tomcat 4.0 release notes:
Enabling SSI and CGI Support:
----------------------------
Having CGI and SSI available to web applications created security problems when using a security manager (as a malicious web application could use them to sidestep the security manager access control). In Tomcat 4.0.1, they have been
disabled by default, as our goal is to provide a fully secure default configuration. However, CGI and SSI remain available in Tomcat 4.0.1.
On Windows:
* rename the file %CATALINA_HOME%\server\lib\servlets-cgi.renametojar to
%CATALINA_HOME%\server\lib\servlets-cgi.jar.
* rename the file %CATALINA_HOME%\server\lib\servlets-ssi.renametojar to
%CATALINA_HOME%\server\lib\servlets-ssi.jar.
* in %CATALINA_HOME%\conf\web.xml, uncomment the servlet declarations starting line 165 and 213, as well as the associated servlet mappings line 265 and 274. Alternately, these servlet declarations and mappings can be added to your web application deployment descriptor.
On Unix:
* rename the file $CATALINA_HOME/server/lib/servlets-cgi.renametojar to
$CATALINA_HOME/server/lib/servlets-cgi.jar.
* rename the file $CATALINA_HOME/server/lib/servlets-ssi.renametojar to
$CATALINA_HOME/server/lib/servlets-ssi.jar.
* in $CATALINA_HOME/conf/web.xml, uncomment the servlet declarations starting
line 165 and 213, as well as the associated servlet mappings
line 265 and 274. Alternately, these servlet declarations and mappings can
be added to your web application deployment descriptor.


Associate Instructor - Hofstra University
Amazon Top 750 reviewer - Blog - Unresolved References - Book Review Blog
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Problem with Server-Side Include (SSI)
 
Similar Threads
tomcat/apache + server side includes
include html in another html
Server-Side Includes (SSI)
include contents of an .inc file as in HTML pages
tomcat- set JAVA_HOME point to jdk..