aspose file tools*
The moose likes Tomcat and the fly likes can't use Jsp with Tomcat 4.03 and jdk1.4 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "can Watch "can New topic
Author

can't use Jsp with Tomcat 4.03 and jdk1.4

Enrico Mannarino
Ranch Hand

Joined: Dec 14, 2001
Posts: 133
Hi,
I'm using jdk1.4 with Tomcat 4.0.3 and I can't compile a jsp-page!
Anybody who has seen this before? Or anyone that really can use Tomcat 4.0.3 with jdk1.4?

org.apache.jasper.JasperException: Unable to compile class for JSPerror: Invalid class file format in c:\j2sdk1.4.0\jre\lib\rt.jar(java/lang/Object.class). The major.minor version '48.0' is too recent for this tool to understand.

/Enrico
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: can't use Jsp with Tomcat 4.03 and jdk1.4