This week's book giveaway is in the OCPJP forum.
We're giving away four copies of OCA/OCP Java SE 7 Programmer I & II Study Guide and have Kathy Sierra & Bert Bates on-line!
See this thread for details.
The moose likes Tomcat and the fly likes tomcat 4.0.4 & db-connection problem. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "tomcat 4.0.4 & db-connection problem. " Watch "tomcat 4.0.4 & db-connection problem. " New topic
Author

tomcat 4.0.4 & db-connection problem.

roni suvanto
Greenhorn

Joined: Jul 23, 2002
Posts: 13
Hello all,
I'm having hard time trying to connect to mysql database. I'm totally newbie what comes to tomcat, but after spending hours with manuals and google without no luck, I decided to ask you gurus.
So, I'm using Tomcat 4.0.4/MySQL 3.23.51, JDK1.3.1_04 & J2SDK1.4.0_01 under win2k.
First I had Tomcat using the 1.4.0, but when I tried to connect to the database, the result was the following error;
org.apache.jasper.JasperException: Unable to compile class for JSPNote: sun.tools.javac.Main has been deprecated.
After spending some time with the google, I found out that there is a problem with Tomcat and 1.4.0 when connecting to databases, and the solution is to use older version.
So I downloaded JDK1.3.1_04 and but it still doesn't work. This time the error is;
javax.servlet.ServletException: sun/tools/javac/Main (Unsupported major.minor version 48.0)
Any suggestions ?
roni suvanto
Greenhorn

Joined: Jul 23, 2002
Posts: 13
problem solved.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: tomcat 4.0.4 & db-connection problem.