This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Tomcat and the fly likes Tomcat 3 and WebSphere Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat 3 and WebSphere" Watch "Tomcat 3 and WebSphere" New topic
Author

Tomcat 3 and WebSphere

Brian Coles
Greenhorn

Joined: Jul 25, 2002
Posts: 6
I've got a site hosted on a tomcat 3.3 and I'm trying to connect to an EJB on a remote WebSphere machine.
I'm having trouble establishing the Initial Context.
I'm providing the Initial Context a properties object with an entry for the provider URL and an entry for the IC factory. For the factory, I'm using "com.ibm.websphere.naming.WsnInitialContextFactory"
Originally, I was getting a ClassNotFoundError on the above class. I included a jar file into my lib that contains that class, but now I'm getting a ClassNotFoundError on com.ibm.ejs.ras.TraceElement
Does anyone know what all I need to include in my lib directory/classpath to get this puppy to run?
Thanks!
Anonymous
Ranch Hand

Joined: Nov 22, 2008
Posts: 18944
Sounds like a Websphere question. I'm moving it there.
Also,
The user name that you have chosen is not in keeping with the Official Javaranch Naming Policy. Please choose a name that complies.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Tomcat 3 and WebSphere
 
Similar Threads
where to put my "mysql-5.0.3-bin.jar" file
Can't get definitions factory from context.
Error in Loading WAR file
Tomcat 3 and WebSphere
Problems with DataSources (NoClassDefFoundError: com/ibm/ejs/sm/beans/RepositoryOb...