Win a copy of Think Java: How to Think Like a Computer Scientist this week in the Java in General forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

mod_webapp build help?

 
Takeshi Toyohara
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
howdy all.
i tried searching around on here and on google for some decent instructions on how to build the mod_webapp.so, but with no such luck.
i downloaded the jakarta-tomcat-connectors tarball. i have apache13 and tomcat4 installed.
i downloaded the apr src and ran buildconf.sh and then did a ./configure --with-apxs=....
that went off w/o a hitch. i then went to apache-1.3/ and did a 'make', but it failed with the following output. anyone have any ideas whats wrong?
thanks in advance

PS - am i correct in assuming also that mod_jk is for tomcat3 only?
thanks
[ August 13, 2002: Message edited by: Takeshi Toyohara ]
 
Takeshi Toyohara
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hate to answer my own question, but i rm'd the dir and replaced it form the tarball and it worked!
so -
make sure you DL the apr-tomcat tarball and put it inside the tomcat-connectors-src/ dir.
then run support/buildconf.sh
then run ./configure --with-apxs=[path to apxs]
then run make
and then everything compiled perfectly. so strange...
 
Michael Jaeger
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
mod_jk is working fine with Tomcat 4.x.x as is usually the prefered option
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic