This week's giveaway is in the Spring forum.
We're giving away four copies of REST with Spring (video course) and have Eugen Paraschiv on-line!
See this thread for details.
The moose likes Tomcat and the fly likes Warp engine and Resource Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Warp engine and Resource" Watch "Warp engine and Resource" New topic

Warp engine and Resource

Ranch Hand

Joined: Nov 22, 2008
Posts: 18944
I have a Web-application which I'm trying to deploy under mod_webapp on Tomcat 4.0 and Apache. In this web-app I have a database resource defined as:
<Resource name="jdbc/dataSource"
But whenever I try to access this on my Tomcat 4.0 through the Apache Warp connector, my lookup fails. Running this on standalone I have no problems with my code.
I've tried to place this directly under <Engine>, under <DefaultContext>, under <Host>, and under a specific context <Context> but without luck.
I've also tried to place it under the normal HTTP connector - also with no luck.
How do I go about getting this to work? Is this a flaw in Tomcat 4 og the webapp mod in Apache?

S�ren Berg Glasius
Consider Paul's rocket mass heater.
subject: Warp engine and Resource
It's not a secret anymore!