This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Tomcat and the fly likes Warp engine and Resource Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Warp engine and Resource" Watch "Warp engine and Resource" New topic
Author

Warp engine and Resource

Anonymous
Ranch Hand

Joined: Nov 22, 2008
Posts: 18944
Hi
I have a Web-application which I'm trying to deploy under mod_webapp on Tomcat 4.0 and Apache. In this web-app I have a database resource defined as:
<Resource name="jdbc/dataSource"
auth="container"
type="javax.sql.DataSource"/>
<ResourceParams>
...
</ResourceParams>
But whenever I try to access this on my Tomcat 4.0 through the Apache Warp connector, my lookup fails. Running this on standalone I have no problems with my code.
I've tried to place this directly under <Engine>, under <DefaultContext>, under <Host>, and under a specific context <Context> but without luck.
I've also tried to place it under the normal HTTP connector - also with no luck.
How do I go about getting this to work? Is this a flaw in Tomcat 4 og the webapp mod in Apache?

Regards,
S�ren Berg Glasius
 
 
subject: Warp engine and Resource
 
Similar Threads
tomcat 4 - apache - mod_webapp problem
Security Contraints setup..
tomcat.startup..inquiry
warp conn prevents apache redirect
DataSource Invalid