aspose file tools*
The moose likes Tomcat and the fly likes Unable to start Tomcat Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Unable to start Tomcat" Watch "Unable to start Tomcat" New topic
Author

Unable to start Tomcat

sm j
Greenhorn

Joined: Oct 07, 2002
Posts: 5
hi all...am in a windows NT workstation 4.0
have insatlled tomcat 4.0.5
i ran catalina run and getting the error:
CATALINA_BASE: d:/tomcat/tom
using CATALINA_HOME: d:/tomcat/tom
using CATALINA_TMPDIR: d:/tomcat/tom/temp
using CATALINA_BASE: d:/tomcat/tom
using JAVA_HOME: d:/jdk1.2.2
bootstrap classloader creation threw exception
java.lang.IllegalMonitorStateException:current thread not owner

i set my classpath & it contains:
CLASSPATH=%CLASSPATH%d:\jdk1.2.2\bin;d:\jdk1.2.2\lib\dt.jar;d:\jdk1.2.2\lib\tools.jar;d:\tomcat\tom\classes;d:\tomcat\tom\lib\jasper-compiler.jar;d:\tomcat\tom\lib\jasper-runtime.jar;d:\tomcat\tom\lib\naming-factory.jar;d:\tomcat\tom\bin\bootstrap.jar
path=d:\jdk1.2.2\bin
can someone help...
cheers!
Fred Grott
Ranch Hand

Joined: Oct 05, 2002
Posts: 346
Maybe I am not understanding you.. what is in the tom directory under tomcat folder? the tom subdirectory is a new one in that its never created in regular install..
I think you meant to not have a tom directory within your paths


MobileBytes blog - Sharing Technology - My Programming Knols
Melanie
Greenhorn

Joined: Oct 07, 2002
Posts: 4
hey..this is sm j in a diff id..
ok..so my bib , lib all folders are inside tom which is inside tomcat folder. no issues abt that rite....and 1 more thing i have jdk1.2.2. that too shudnt be a problem with tomcat 4.0.5...so where is the problem?
Simon Brown
sharp shooter, and author
Ranch Hand

Joined: May 10, 2000
Posts: 1913
    
    6
"Malisun",
Thanks for joining JavaRanch, but could you just take a quick look at the naming policy and edit your profile accordingly.
Also, moving this to the Tomcat forum...
Thanks!
Simon
Bartender (moderator) of "J2EE and EJB" forum
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16142
    
  21

1. You should place a semicolon( ; ) after that %CLASSPATH% to separate it from the D:\ that follows. That way if you didn't include a final semicolon at the end of the CLASSPATH environment value you won't see the last path in the pathname get concatenated into the first post"%" item to their mutual dismay. Too many semicolons won't hurt (unless your environment size is too small anyway!). Too few is trouble.
2. You don't need to (and shouldn't) explicitly mention every Tomcat directory and jar, since Tomcat builds classloaders to handle that kind of stuff. So anything that you added that wasn't in the sample .BAT startup file you downloaded with Tomcat can be safely removed.
[ October 08, 2002: Message edited by: Tim Holloway ]

Customer surveys are for companies who didn't pay proper attention to begin with.
Melanie
Greenhorn

Joined: Oct 07, 2002
Posts: 4
hi..i tried what u sd..but the problem persits...here's teh alboration...patience requested!!
Hi..i ve downloaded Tomcat version 4.0.5 frm the apache website
in windows NT workstation 4.0 with JDK 1.2.2 and in windows 98 with JDK1.2.2
these are my systsm variables value in windows 98 where i have installed.
JAVA_HOME=d:\jdk1.2.2
CATALINA_HOME=d:\tomcat
CLASSPATH=d:\jdk1.2.2\bin
PATH=c:\windows;c:\windows\command;d:\jdk1.2.2\bin
Now after installation , when i give startup at the command prompt..i get he following
Using CATALINA_BASE :\tomcat
Using CATALINA_HOME :\tomcat
Using CATALINA_TEMDIR :\tomcat\temp
Using JAVA_HOME :\jdk1.2.2
then the prompt reappears. I can see another window flasing but it disappears.
when i give catalina run at the prompt i get the following:

Using CATALINA_BASE :\tomcat
Using CATALINA_HOME :\tomcat
Using CATALINA_TEMDIR :\tomcat\temp
Using JAVA_HOME :\jdk1.2.2
Bootstrap:Class loader creation threw exception
java.lang.IllegealMonitorStateException: Current thread not owner.
I went thro the catalina.bat file. It calls startup.bat. Eventually the classpath gets set to
CLASSPATH=d:\jdk1.2.2\lib\tools.jar;d:\tomcat\bin\bootstrap.jar

Using statements that get displayed are frm the catalina.bat file.
I unjarred the bootstrap.jar to find
bootstrap.class in the org/apche/catalina/startup folder. Since
its a class file i cudnt proceed further. Think the Bootstrap eeror
is generated from there. But could be because of other reasons too that i dont know.
I am getting the same error in windows Nt system too.
Maybe u could also forward this to freinds working with tomcat &
its installation and check out.
thanks
PS: does anyone think its cos of JDK1.2.2..but then the tomcat dod clearly says java 1.2 or later version is fine. kinda urgent..help out..
 
jQuery in Action, 2nd edition
 
subject: Unable to start Tomcat