aspose file tools*
The moose likes Tomcat and the fly likes webapps/war file not deploying automatically in tomcat4.0.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "webapps/war file not deploying automatically in tomcat4.0.1" Watch "webapps/war file not deploying automatically in tomcat4.0.1" New topic
Author

webapps/war file not deploying automatically in tomcat4.0.1

Dez Max
Ranch Hand

Joined: Oct 01, 2002
Posts: 41
Hi All,
I've packaged my web-application in a war file and placed under webapps directory. I've enter the context too in server.xml. The unpacked attribute of server.xml is also set to true. When the server starts up its suppose to deploy the war file automatically but its no doing so. Did i missed out anything else?
Help...
Fred
Mike Curwen
Ranch Hand

Joined: Feb 20, 2001
Posts: 3695

When you put the war file into webapps, and just don't use any Context information in server.xml (ie: do *not* put a context there for your webapp), Tomcat has been able to unpack the WAR.

If you have a context, however, Tomcat isn't so smart..even with the proper attribute in place. That's been my experience.

So what if you want to set things up in your Context, like loggers ? You need to unpack the WAR file yourself, is the short answer.
Mike Curwen
Ranch Hand

Joined: Feb 20, 2001
Posts: 3695

Yup, I thought I had answered that one before.

http://www.coderanch.com/t/81715/Tomcat/Tomcat-unpacking-wars
Mike Curwen
Ranch Hand

Joined: Feb 20, 2001
Posts: 3695

p.s. 'Fred'

Please refer to our naming policy
[ October 27, 2002: Message edited by: Mike Curwen ]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: webapps/war file not deploying automatically in tomcat4.0.1