permaculture playing cards*
The moose likes Tomcat and the fly likes HELP - Can't get Tomcat Working!! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » Tomcat
Reply locked New topic
Author

HELP - Can't get Tomcat Working!!

Con Lu
Ranch Hand

Joined: Aug 27, 2002
Posts: 38
I seem to be able to start up Tomcat okay, but my browser does not seem to access the default Tomcat home page, or any other servlet classes. Note that I am a beginner in Web technology.
I have installed and tested Tomcat 4.0.1 on Win 2000Prof with the following procedure:-
1)Installed JDK1.4 on my machine
2)Installed the Jakarta-tomcat-4.0.1.exe files to directory called d:\Tomcat
3)Set the environment variable CATALINA_HOME to d:\Tomcat
4)Set the JAVA_HOME variable to d:\j2sdk1.4.0
5)Changed the classpath to include d:\Tomcat\common\lib\servlet.jar
6)Opened up a DOS prompt and gone to d:\Tomcat\bin
7)Typed echo %JAVA_HOME% and echo %CATALINA_HOME% to check the variables are correctly set
8)Typed the command startup which starts Tomcat in a separate window
9)I open my Internet Explorer 5 browser
10)I type in http://localhost:8080
11)Instead of getting the default Tomcat page I get a page similar to the following:-
Index of
NameLast modifiedSize
public/
sys/
Xdbconfig.xml
12)When I add any other input to the url in 10) above such as http://localhost:8080/index.html as directed in a Wrox text book, my browser prompts me to connect
13)After connecting the lower right hand side of my browser shows that I am on a local intranet, but all that comes up is a “Page cannot be found error”
14)I have tried the SCWCD Manning book examples by doing the following :-
Tomcat\webapps\chapter01\WEBINF\classes\HelloWorldServlet.class
15)After restarting Tomcat I try to type in http://localhost:8080/chapter01/servlet/HelloWorldServlet
16)Again my browser asks me to connect so I do
17)Once connected I again get a “Page cannot be found error”
Other queries/info which may relate in solving the above:-
1)I don’t know if this is related but when I shutdown a java.net.Connection error is shown on my screen with a large stack trace that goes through from top to bottom as follows:-
java.net.PlainSocketImp,
java.net.Socket,
org.apache.catalina.startup,
org.apache.catalina.execute
org.apache.catalina.process
sun.reflect.NativeMethodAccessorImpl, sun.reflect.DelegatingMethodAccessorImp.invoke()
java.lang.reflect.Method.invoke()
org.apache.catalina.startup.main()
2)Furthermore, I don’t know if this is of any significance, but I have previously Oracle9i installed on my computer which automatically installed what appears to be Apache HTTP server. Could this be causing some sort of conflict?
I have been tearing my hair out trying to solve this problem. Any help would be very much appreciated.
Cindy Glass
"The Hood"
Sheriff

Joined: Sep 29, 2000
Posts: 8521
Please do not cross post. Continue the conversation here.


"JavaRanch, where the deer and the Certified play" - David O'Meara
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: HELP - Can't get Tomcat Working!!