aspose file tools*
The moose likes Tomcat and the fly likes Problem setting up the SSL of Tomcat 4.1.12 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Problem setting up the SSL of Tomcat 4.1.12" Watch "Problem setting up the SSL of Tomcat 4.1.12" New topic
Author

Problem setting up the SSL of Tomcat 4.1.12

Mark Lau
Ranch Hand

Joined: Dec 15, 2001
Posts: 120
Hi,
I am attempting to setup tomcat's SSL, but failed.
I am using tomcat 4.1.12, j2sdk1.4.1_01 and Win2K professional.
Running tomcat without SSL is successful.
Then I followed the instruction of tomcat-ssl-howto and generated the .keystore file, modified server.xml.
Then when I start tomcat, I get the following severe handshake error and if do http://localhost:8443 in my browser, I see nothing except a completely blank page.
Would you gurus please kindly tell me how to fix this? Thanks a lot!
Created catalinaLoader in: C:\Tomcat4_1_12\server\lib
Nov 13, 2002 4:20:15 PM org.apache.commons.modeler.Registry loadRegistry
INFO: Loading registry information
Nov 13, 2002 4:20:17 PM org.apache.commons.modeler.Registry getRegistry
INFO: Creating new Registry instance
Nov 13, 2002 4:20:24 PM org.apache.commons.modeler.Registry getServer
INFO: Creating MBeanServer
Nov 13, 2002 4:20:34 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on port 80
Nov 13, 2002 4:20:52 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on port 443
Nov 13, 2002 4:21:59 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on port 80
Nov 13, 2002 4:21:59 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on port 443
Nov 13, 2002 4:21:59 PM org.apache.jk.common.ChannelSocket init
INFO: JK2: ajp13 listening on tcp port 8009
Nov 13, 2002 4:21:59 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=580/571 config=C:\Tomcat4_1_12\conf\jk2.properties
Nov 13, 2002 4:23:22 PM org.apache.tomcat.util.log.CommonLogHandler log
SEVERE: Handshake failed
javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?
at com.sun.net.ssl.internal.ssl.InputRecord.b(DashoA6275)
at com.sun.net.ssl.internal.ssl.InputRecord.read(DashoA6275)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.a(DashoA6275)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.j(DashoA6275)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(DashoA6275)
at org.apache.tomcat.util.net.JSSESocketFactory.handshake(JSSESocketFactory.java:290)
at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:493)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:533)
at java.lang.Thread.run(Thread.java:536)
Nov 13, 2002 4:23:22 PM org.apache.tomcat.util.log.CommonLogHandler log
SEVERE: Caught exception executing org.apache.tomcat.util.net.TcpWorkerThread@18488ef, terminating thread
java.lang.NullPointerException
at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:512)
at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:533)
at java.lang.Thread.run(Thread.java:536)
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem setting up the SSL of Tomcat 4.1.12