wood burning stoves*
The moose likes Tomcat and the fly likes ManegedBean is not fund exception Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "ManegedBean is not fund exception" Watch "ManegedBean is not fund exception" New topic
Author

ManegedBean is not fund exception

Adam Adams
Ranch Hand

Joined: Nov 28, 2001
Posts: 60
i hahave problem ri=unning iplanet/tomcat using ajp13. below is the exception i get. any input is highly apreciated.
ServerLifecycleListener: createMBeans: MBeanException
java.lang.Exception: ManagedBean is not found with Ajp13Connector
at org.apache.catalina.mbeans.MBeanUtils.createMBean(MBeanUtils.java:225
)
at org.apache.catalina.mbeans.ServerLifecycleListener.createMBeans(Serve
rLifecycleListener.java:369)
at org.apache.catalina.mbeans.ServerLifecycleListener.createMBeans(Serve
rLifecycleListener.java:777)
at org.apache.catalina.mbeans.ServerLifecycleListener.createMBeans(Serve
rLifecycleListener.java:751)
at org.apache.catalina.mbeans.ServerLifecycleListener.createMBeans(Serve
rLifecycleListener.java:339)
at org.apache.catalina.mbeans.ServerLifecycleListener.lifecycleEvent(Ser
verLifecycleListener.java:206)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(Lifecycl
eSupport.java:166)
Michael Mendelson
Ranch Hand

Joined: Dec 19, 2000
Posts: 73
Adam, have you solved this problem? I can't give you a solution but can provide more information.
Evidently there's a ManagedBean set up for each "managed object" in Catalina (e.g. Valves, Realms, etc.). See http://jakarta.apache.org/tomcat/tomcat-4.1-doc/catalina/funcspecs/mbean-names.html.
I ran into this issue when setting up a new Realm. Evidently all the information listed on the page referenced above comes from an xml file located at org\apache\catalina\mbeans\mbeans-descriptors.xml. (I found it by following that stack trace. It's read by org\apache\catalina\mbeans\MBeanUtils.java, if you have the source.)
What I did was to modify this file, and save it as TOMCAT_HOME\server\classes\org\apache\catalina\mbeans\mbeans-descriptors.xml, so it gets "found" in the classpath before the one in catalina.jar.
I just modeled my entry on a similar class.
My hunch is that this is used to define/pass parameters from server.xml and web.xml. However, there must be a more elegant way to handle this!
It was certainly not an issue in 4.0. :roll:
Bashar Abdullah
Greenhorn

Joined: Mar 29, 2005
Posts: 14
Hi Michael,

I know this is an old post, but if you still remember, can you guide me on what parameters I should be modifying. It seems like a hell lot of data and its hard to figure it out.
Michael Mendelson
Ranch Hand

Joined: Dec 19, 2000
Posts: 73
Unfortunately this was a long time ago and I don't work in the Tomcat environment any more. To make matters worse, I don't even have that source code. I'll tell you what I remember:

I was created a Tomcat Realm, so that I could custom-configure my security settings in the server.xml file. The mbeans-descriptors.xml file defines that inerface. What I did was to take the out-of-the-box mbeans-descriptors.xml and adding my class to it. Because my class was an extension of the Realm class, I took the descriptor for the Realm, extended it, and added a new entry.

Then it was a matter of where to put the class so that tomcat would "see" it, and pick it up BEFORE the original mbeans-descriptors.xml.

I did that as described above.

Good luck, and sorry I don't have more details...
Bashar Abdullah
Greenhorn

Joined: Mar 29, 2005
Posts: 14
Thanks a lot
You've done enough. But I think my problem is a bit different. Thanks for sharing your thoughts with me thought.

Regards
Bashar
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: ManegedBean is not fund exception
 
Similar Threads
Apache-Tomcat integration issues
EclipseIDE 3.6 + Tomcat 5.5 exception
JDBCRealm in Tomcat 4.1
tomcat.startup..inquiry
Starting tomcat 4.1.12