Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Going nuts with Tomcat 4, JK2, and IIS

 
Phil Chuang
Ranch Hand
Posts: 251
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am going absolutely nuts trying to get Tomcat and IIS to play nice together. I think I've narrowed down the culprit to my jk2/workers2.properties files, as the IIS logs seem to show it connecting to the isapi_redirector2.dll, but returning an http error 500 (internal server error).
Someone please help me before my brain melts!
-------------
I am running tomcat in-process, so I made sure that it is not running when I start up IIS, and have verified that IIS starts it up correctly.
the ISAPI filter is configured correctly (at least, it's green).
jakarta virtual directory has been made and points to the directory of isapi_redirector2.dll
Here are my settings:
REGISTRY,
HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi Redirector\2.0
--------------------------------------
extensionUri = /jakarta/isapi_redirector2.dll
logLevel = debug
serverRoot = c:\tomcat4
workersFile = C:\tomcat4\conf\workers2.properties

SERVER.XML
--------------------------------------
ajp13 connector is uncommented
JK2.PROPERTIES
--------------------------------------
handler.list=apr,request,container,channelJni
apr.jniModeSo=inprocess
WORKERS2.PROPERTIES
--------------------------------------
[logger]
level=debug
[status:]
info=Status worker, displays runtime informations
# Define the comunication channel
[channel.jni:jni]
info=The jni channel, used if tomcat is started inprocess
# Define the parameters for the Java Virtual Machine
[vm:]
info=Parameters used to load a JVM in the server process
JVM=C:\jdk141\jre\bin\client\jvm.dll
#OPT=-Djava.class.path=C:\tomcat4/bin/tomcat-jni.jar;C:\tomcat4/bin/bootstrap.jar;C:\tomcat4/server/lib/commons-logging.jar
OPT=-Djava.class.path=C:\tomcat4/bin/tomcat-jni.jar
OPT=-Dtomcat.home=C:\tomcat4
OPT=-Dcatalina.home=C:\tomcat4
OPT=-Xmx128M
disabled=0
# JNI worker startup handler
[worker.jni nStartup]
info=Command to be executed by the VM on startup. This one will start tomcat.
class=org/apache/jk/apr/TomcatStarter
ARG=start
stdout=C:\tomcat4/logs/stdout.log
stderr=C:\tomcat4/logs/stderr.log
disabled=0
# JNI worker shutdown handler
[worker.jni nShutdown]
info=Command to be executed by the VM on shutdown. This one will stop tomcat.
class=org/apache/jk/apr/TomcatStarter
ARG=stop
disabled=0
[lb:lb]
info=Default load balancer.
debug=0
# Define the communication channel
[channel.socket:localhost:8009]
info=Ajp13 forwarding over socket
tomcatId=localhost:8009
[uriMap:]
info=Maps the requests. Options: debug
debug=0
# Map the Tomcat examples webapp to the Web server uri space
[uri:/servlets/*]
info=Maps servlets
[uri:/*.jsp]
info=Maps all .jsp files
[uri:/jkstatus/*]
info=Display status information and checks the config file for changes.
group=status:
 
Phil Chuang
Ranch Hand
Posts: 251
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You know, if I had seen this line
------------------
# In order to enable jni use any channelJni directive
# channelJni.disabled = 0
------------------
a lot earlier I could have saved myself two days....
sigh.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic