wood burning stoves 2.0*
The moose likes Tomcat and the fly likes How to deploy my own webapplication Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "How to deploy my own webapplication" Watch "How to deploy my own webapplication" New topic
Author

How to deploy my own webapplication

djyoti sahu
Greenhorn

Joined: Jan 28, 2003
Posts: 26
Hai
all,

i am using tomcat 4.*.
I downloaded from apache.

Servlet executes if i store class file in E:\Program Files\Apache Tomcat 4.0\webapps\examples\WEB-INF\classes


but i have created my own webdirectory(jyotiweb) in E:\Program Files\Apache Tomcat 4.0\webapps
i created WEB-INF file in E:\Program Files\Apache Tomcat 4.0\webapps\Jyotiweb
i created classes file in E:\Program Files\Apache Tomcat 4.0\webapps\Jyotiweb\WEB-INF


save my hallo class file in E:\Program Files\Apache Tomcat 4.0\webapps\Jyotiweb\WEB-INF\classes

save my web.xml in E:\Program Files\Apache Tomcat 4.0\webapps\Jyotiweb\WEB-INF


in browser enter--


http://localhost:8080/jyotiweb/servlet/Hallo


but show error
Apache Tomcat/4.0.1 - HTTP Status 404 - /jyotiweb/servlet/Hallo
--------------------------------------------------------------------------------
tApache Tomcat/4.0.1 - HTTP Status 404 - /jyotiweb/servlet/Hallo
--------------------------------------------------------------------------------
dtype Status report

message /jyotiweb/servlet/Hallo
description The requested resource (/jyotiweb/servlet/Hallo) is not available.
Mike Curwen
Ranch Hand

Joined: Feb 20, 2001
Posts: 3695

/servlet is disabled by default.

You need to enable it in order to use this mapping. But you already have your WEB-INF file, so the better alternative is to provide a servlet mapping and use that instead.
djyoti sahu
Greenhorn

Joined: Jan 28, 2003
Posts: 26
please tell me how to do this mapping.
Tristan Curry
Greenhorn

Joined: Mar 11, 2003
Posts: 1
Had the same problem put this in a file called web.xml in the WEB-INF directory of your app:

Should do the trick
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: How to deploy my own webapplication