aspose file tools*
The moose likes Tomcat and the fly likes Tomcat4.1.18 with jdk1.4.1_02 problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat4.1.18 with jdk1.4.1_02 problem" Watch "Tomcat4.1.18 with jdk1.4.1_02 problem" New topic
Author

Tomcat4.1.18 with jdk1.4.1_02 problem

Debashish Chakrabarty
Ranch Hand

Joined: May 14, 2002
Posts: 230

Hi Ranchers,
In reply to my earlier post many had replied that Tomcat4.1.x works well with jdk1.4.x and there is no compatibility problem. Some have been using the combination since months.
I tried this today but on trying a jsp page in my application I get the following error message:

I earlier thought that the error might be due to some JRE version conflict since I had both jdk1.3 and this particular version of jdk installed on my XP machine. So I uninstalled the jsdk as well as JRE for jdk1.3, restarted my machine but alas the same error persists. Please note that the Tomcat server starts and runs well.
Any clues??
Thanks & Regards,
[ March 12, 2003: Message edited by: Debashish Chakrabarty ]

Debashish
SCJP2, SCWCD 1.4, PMP, ITIL Foundation
Rene Larsen
Ranch Hand

Joined: Oct 12, 2001
Posts: 1179

The error means that you are trying to run some code compiled with a newer java version then the one using now.

which path is in your JAVA_HOME
Rene
[ March 12, 2003: Message edited by: Rene Larsen ]

Regards, Rene Larsen
Dropbox Invite
praveen patil
Greenhorn

Joined: Mar 03, 2003
Posts: 9
hi deb,
set up all HOME_PATHs of JDK1.4,Tomcat,Catalina,
Jasper & include CLASSPATHs of JDK tools.jar &
Servlet.jar of Tomcat lib file. for this u can
write ur own batch file & run this before start
of Tomcat.

Praveen
N Val
Greenhorn

Joined: Feb 20, 2003
Posts: 10
Hi all of u!
I am having the same problem with jdk1.4.1_01 and Tomcat4.1.18
Are they both really not compatible? Do i have to download jdk1.3?
I tried all possible ways of starting the server but looks like no use.
I hit this page somewhere on the net.
http://www.moreservlets.com/Using-Tomcat-4.html#Enable-Root-Context
Do i need to do everything that's written on this page? I mean like changing the server.xml and web.xml files?
I really need help. Can anyone help me here?
Thanks in Advance.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat4.1.18 with jdk1.4.1_02 problem