This week's book giveaways are in the Refactoring and Agile forums.
We're giving away four copies each of Re-engineering Legacy Software and Docker in Action and have the authors on-line!
See this thread and this one for details.
Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Getting userDir to work in apache

 
Gregg Bolinger
GenRocket Founder
Ranch Hand
Posts: 15302
6
Chrome IntelliJ IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I know this isn't java related but I am having a problem getting the UserDir to work in apache. I have it set to UserDir /www/public_html and then when I access my web server via http://ethought.com/~gdboling/index.html or http://ethought.com/~gdboling/www/public_html/index.html
It is not working. But the web server is working fine with everything else.
Is there something I am missing?
 
Andrew Monkhouse
author and jackaroo
Marshal Commander
Pie
Posts: 11854
185
C++ Firefox Browser IntelliJ IDE Java Mac Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Gregg
The directive you are looking for should be:

From the sample configuration file normally provided with Apache:

If you are using Apache 2.x, you should also ensure that you dont have the UserDir disable directive.
Regards, Andrew
 
Gregg Bolinger
GenRocket Founder
Ranch Hand
Posts: 15302
6
Chrome IntelliJ IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Andrew Monkhouse:
Hi Gregg
If you are using Apache 2.x, you should also ensure that you dont have the UserDir disable directive.

I think this might be my problem. Thanks Andrew, I will let you know...
 
Gregg Bolinger
GenRocket Founder
Ranch Hand
Posts: 15302
6
Chrome IntelliJ IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well, I added the UserDir enabled gdboling and now I am getting a Forbidden: You don't have permissions to access /~gdboling/index.html on this server.
So I added under my UserDir public_html
<directory>
.....
</directory>
To allow access as read only. Basically just had to uncomment thos lines that were already set for me by default.
Any more suggestions?
 
Andrew Monkhouse
author and jackaroo
Marshal Commander
Pie
Posts: 11854
185
C++ Firefox Browser IntelliJ IDE Java Mac Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Gregg,
My entire set of directives are:
I have not bothered to uncomment the /home/*/public_html directory settings.
My permissions are:

And this works for me: I can acces my personal web page using the http://192.168.1.1/~andrewm/ address.
What does your error log show at the time you try to access your personal web page?
Regards, Andrew
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic