aspose file tools*
The moose likes Tomcat and the fly likes Tomcat 4.1.24 problems Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat 4.1.24 problems" Watch "Tomcat 4.1.24 problems" New topic
Author

Tomcat 4.1.24 problems

Mike London
Ranch Hand

Joined: Jul 12, 2002
Posts: 1083
I thought an upgrade from 4.1.18 to 4.1.24 would be a snap. No so.
I un-installed 4.1.18 and then installed 4.1.24 and tried to run an "http://localhost/index.jsp".
To my surprise, I got the error below.
----------------------------------------
org.apache.jasper.JasperException: Unable to compile class for JSP
An error occurred at line: -1 in the jsp file: null
Generated servlet error:
[javac] Since fork is true, ignoring compiler setting.
[javac] Compiling 1 source file
[javac] Since fork is true, ignoring compiler setting.
(plus the usual Tomcat dump of 50 or so other errors)
------------------------------------
I also tried copying in my old conf files which worked under 4.1.18.
Anybody had this situation or can suggest a remedy?
Thank you.
--Mike
P.S. Re-installing 4.1.18 seemed to work fine, but that isn't my goal....<s>
Mike London
Ranch Hand

Joined: Jul 12, 2002
Posts: 1083
After I posted my problem report above I noticed others were having the same problem as I was.
Here's a a listing from devshed that fixed my problem as well (REGEDIT to the rescue!). It appears to be a bug in the 4.1.24 service installation setting:
================================================
If you're trying to run Tomcat 4.1 (in my case, 4.1.24) on WinXP as a service, there appears to be a misconfiguration in the service installation. The JVM Library registry entry points to the jvm.dll that's part of the JRE, not the installed JDK. Tomcat needs to be able to find javac to compile JSPs.
I changed mine from C:\Program Files\Java\j2re1.4.1_01\bin\client\jvm.dll to C:\Program Files\jre\bin\client\jvm.dll, restarted the service, and everything's fine. Interestingly enough, the Start Tomcat shortcut worked perfectly, it was just the service that was hosed.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat 4.1.24 problems