GeeCON Prague 2014*
The moose likes Tomcat and the fly likes web application not coming up when tomcat4.0.6 is started as a service Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Tomcat
Bookmark "web application not coming up when tomcat4.0.6 is started as a service" Watch "web application not coming up when tomcat4.0.6 is started as a service" New topic
Author

web application not coming up when tomcat4.0.6 is started as a service

kalpana s
Greenhorn

Joined: Dec 22, 2003
Posts: 8
hi all,

I have a struts based web application on tomcat 4.0.6.

I start tomcat4.0.6 manually using C:\jakarta-tomcat-4.0.6\bin\startup, the application comes up successfully

I have started tomcat4.0.6 as a windows 2k service and when i try to bring up the web application, i get a ServletException.

javax.servlet.ServletException: Cannot find ActionMappings or ActionFormBeans collection
at org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:471)
at org.apache.jsp.logon$jsp._jspService(logon$jsp.java:257)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:107)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at org.apache.jasper.servlet.JspServlet$JspServletWrapper.service(JspServlet.java:201)
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:381)
at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:473)
.
.
root cause
javax.servlet.jsp.JspException: Cannot find ActionMappings or ActionFormBeans collection
at org.apache.struts.taglib.html.FormTag.lookup(FormTag.java:858)
at org.apache.struts.taglib.html.FormTag.doStartTag(FormTag.java:543)
at org.apache.jsp.logon$jsp._jspService(logon$jsp.java:94)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:107)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at org.apache.jasper.servlet.JspServlet$JspServletWrapper.service(JspServlet.java:201)
.
.
Could any body tell me what may be the problem, i am getting this exception for the login page itself....
Its urgent
Thanks in advance
kalpana
 
GeeCON Prague 2014
 
subject: web application not coming up when tomcat4.0.6 is started as a service